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Safety Information 

 

 

The CY8CKIT-044 PSoC® 4 M-Series Pioneer Kit is intended for use as a development platform for hardware or software in 
a laboratory environment. The board is an open system design, which does not include a shielded enclosure. For this 
reason, the board may cause interference with other electrical or electronic devices in close proximity. In a domestic 
environment, this product may cause radio interference. In such cases, the user may be required to take adequate 
preventive measures. Also, this board should not be used near any medical equipment or RF devices. 

Attaching additional wiring to this product or modifying the product operation from the factory default may affect its 
performance and cause interference with other apparatus in the immediate vicinity. If such interference is detected, suitable 
mitigating measures should be taken. 

The CY8CKIT-044 as shipped from the factory has been verified to meet with the requirements of CE as a Class A product. 

 

The CY8CKIT-044 board contains electrostatic discharge (ESD) sensitive devices. 
Electrostatic charges readily accumulate on the human body and any equipment which 
can cause a discharge without detection. Permanent damage may occur to devices 
subjected to high-energy discharges. Proper ESD precautions are recommended to avoid 
performance degradation or loss of functionality. Store unused CY8CKIT-044 boards in the 
protective shipping package. 

 

End-of-Life/Product Recycling 

The end-of-life cycle for this kit is five years from the date of manufacture mentioned on 
the back of the box. Contact the nearest recycler to discard the kit. 

General Safety Instructions 

ESD Protection  

ESD can damage boards and associated components. Cypress recommends that the user perform procedures only at an 
ESD workstation. If an ESD workstation is not available, use appropriate ESD protection by wearing an antistatic wrist strap 
attached to a grounded metal object. 

Handling Boards 

CY8CKIT-044 board is sensitive to ESD. Hold the board only by its edges. After removing the board from its box, place it on 
a grounded, static-free surface. Use a conductive foam pad if available. Do not slide the board over any surface. 
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1.   Introduction 

 

Thank you for your interest in the CY8CKIT-044 PSoC® 4 M-Series Pioneer Kit. The PSoC 4 M-Series Pioneer Kit enables 
customers to evaluate and develop projects using the PSoC 4200M device family.  

PSoC 4200M device family is an expansion to the PSoC 4 device family that offers more flash, GPIOs, and programmable 
analog and digital blocks. PSoC 4200M device is a true programmable embedded system-on chip, integrating custom 
analog and digital peripheral functions, memory, and an Arm® Cortex®-M0 microcontroller on a single chip. The 
programmable analog and digital peripheral functions allow higher flexibility, in-field tuning of the design, and faster time-to-
market.  

The PSoC 4 M-Series Pioneer Kit offers footprint-compatibility with ArduinoÊ Shields, 6-pin Digilent® PmodÊ Peripheral 
Modules, and Raspberry Pi boards. This kit features two CapSense® Proximity headers, a CapSense Gesture Pad, an 
ambient light sensor, a 3-Axis accelerometer, a PWM temperature sensor, an RGB LED, a push button switch, an onboard 
programmer/debugger and USB-UART/I2C bridge functionality block (KitProg), and a Cypress F-RAMÊ. This kit supports 
operating voltages of 3.3 V or 5 V. 

You will use PSoC CreatorÊ to develop and debug your PSoC 4200M device projects. PSoC Creator is Cypressô standard 
integrated design environment (IDE). If you are new to PSoC Creator, see the documentation on the PSoC Creator home 
page. You can also refer the application note AN79953 ï Getting Started with PSoC 4, which gives an introduction to the 
PSoC 4 device. 

1.1   Kit Contents 

The CY8CKIT-044 PSoC 4 M-Series Pioneer Kit contains the following, as shown in Figure 1-1. 

Þ PSoC 4 M-Series Pioneer board 

Þ USB Standard-A to Mini-B cable 

Þ Four jumper wires (4 inches each) 

Þ Two proximity sensor wires (5 inches each) 

Þ Micrium® µC/Probe® license card 

Þ Quick Start Guide 

Note: The Micrium µC/Probe license is valid only for one month from the date of activation. 

http://www.cypress.com/psoccreator
http://www.cypress.com/psoccreator
http://www.cypress.com/?rID=78695
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Figure 1-1. Kit Contents 

 

Inspect the contents of the kit; if you find any part missing, contact your nearest Cypress sales office for help: 
www.cypress.com/support.  

1.2   Board Details  

The PSoC 4 M-Series Pioneer Kit consists of the following blocks, as shown in Figure 1-2. It also shows the pin mapping of 
all headers. 

http://www.cypress.com/support
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Figure 1-2. PSoC 4 M-Series Pioneer Kit Markup 
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1.3   PSoC Creator 

PSoC Creator is a state-of-the-art, easy-to-use IDE. It introduces revolutionary hardware and software codesign, powered 
by a library of preverified and precharacterized PSoC ComponentsÊ, as shown in Figure 1-3. With PSoC Creator, you can: 

Þ Drag and drop Components to build your hardware system design in the main design workspace 

Þ Co-design your application firmware with the PSoC hardware 

Þ Configure Components using configuration tools 

Þ Explore the library of 100+ Components 

Þ Access Component datasheets 

Figure 1-3. PSoC Creator Features 

 

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains and production 
programmers for PSoC devices. 

For more information, visit www.cypress.com/psoccreator. 

http://www.cypress.com/psoccreator
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1.3.1   PSoC Creator Code Examples 
PSoC Creator includes a large number of code examples. These 
examples are accessible from the PSoC Creator Start Page, as 
shown in Figure 1-4. 

Code examples can speed up your design process by starting 
you off with a complete design, instead of a blank page. The 
code examples also show how to use PSoC Creator 
Components for various applications. Code examples and 
documentation are included, as shown in Figure 1-5. 

In the Find Code Example dialog shown in Figure 1-5, you have 
several options: 

Þ Filter for examples based on device family or keyword. 

Þ Select from the list of examples offered based on the Filter 
Options. 

Þ View the project documentation for the selection (on the 
Documentation tab). 

Þ View the code for the selection. You can also copy and 
paste code from this window to your project, which can help 
speed up code development. 

Figure 1-4. Code Examples in PSoC Creator 

 

Þ Create new workspace for the code example. This can speed up your design process by starting you off with a 
complete, basic design. You can then adapt that design to your application. 

Figure 1-5. Sample Code Example 

 

1.3.2   Kit Code Examples 

You can access the installed kit code examples from the PSoC Creator Start Page. To access these code examples, 
expand the Kits under the section Start; then, expand the specific kit to see the code examples. Refer to the Using the Kit 
Code Examples section for a detailed explanation on how to access the kit code examples. 
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1.3.3   PSoC Creator Help 

Launch PSoC Creator and navigate to the following items: 

Þ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you the basics for 
developing PSoC Creator projects. 

Þ Simple Component code examples: Choose File > Code Example. These code examples demonstrate how to 
configure and use PSoC Creator Components. To access code examples related to a specific Component, place the 
Component on the TopDesign schematic and right-click on the Component. Select the Find Code Example option in 
the context menu that appears.  

Þ System Reference Guide: Choose Help > System Reference Guide. This guide lists and describes the system 
functions provided by PSoC Creator. 

Þ Component Datasheets: Right-click a Component and select Open Datasheet. Visit the PSoC 4 Component 
Datasheets page for a list of all PSoC 4 Component datasheets. 

1.4   Getting Started 

This guide will help you be acquainted with the CY8CKIT-044 PSoC 4 M-Series Pioneer Kit: 

Þ The Installation chapter describes the installation of the kit software. This includes the PSoC Creator IDE to develop 
and debug the applications, and PSoC Programmer to program the .hex files on to the device. 

Þ The Kit Operation chapter describes the major features of the PSoC 4 M-Series Pioneer Kit and functionalities such as 
programming, debugging, and the USB-UART and USB-I2C bridges. 

Þ The Code Examples chapter describes multiple PSoC 4200M code examples that will help you understand how to 
create your own PSoC 4 projects. 

Þ The Appendix provides the method to use the Micrium µC/Probe, detailed hardware description, method to use the 
onboard F-RAM, kit schematics, and the bill of materials (BOM). 

1.5   Additional Learning Resources 

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device for your design, and to 
help you to quickly and effectively integrate the device into your design. For a comprehensive list of resources, see  
KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP. The following is an abbreviated list for PSoC 4: 

Þ Overview: PSoC Portfolio and PSoC Roadmap. 

Þ Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device selection tool. 

Þ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, PSoC 4200, PSoC 4100M, 
and PSoC 4200M device families. 

Þ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the PSoC 4 family of 
devices. 

Þ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. Many of the 
application notes include code examples. Visit the PSoC 3/4/5 Code Examples web page for a list of all available PSoC 
Creator code examples. To access code examples from within PSoC Creator ï see PSoC Creator Code Examples. 

Þ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and registers in each PSoC 4 
device family. 

Þ Development Kits: 

Ã CY8CKIT-042 and CY8CKIT-040 are easy-to-use and inexpensive development platforms. These kits include 
connectors for Arduino compatible Shields and Digilent Pmod Peripheral Modules. 

Ã CY8CKIT-049 is a low-cost prototyping platform for sampling PSoC 4 devices. 

Ã CY8CKIT-001 is a common development platform for all PSoC family devices. 

Ã MiniProg3 device provides an interface for flash programming and debug. 

Þ Knowledge Base Articles (KBA): Provide design and application tips from experts on using the device. For instance, 
KBA93541 explains how to use CY8CKIT-049 to program another PSoC 4. 

http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
http://www.cypress.com/
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/psoc
http://www.cypress.com/?rID=86788
http://www.cypress.com/?id=4976
http://www.cypress.com/psoccreator
http://www.cypress.com/?rID=94034&source=an79953
http://www.cypress.com/?rID=78805&source=an79953
http://www.cypress.com/?rID=78632&source=an79953
http://www.cypress.com/documentation/datasheets/psocr-4-psoc-4100m-family-datasheet-programmable-system-chip-psocr
http://www.cypress.com/?rID=108039
http://www.cypress.com/?rID=78578&source=an79953
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=76&id=4749
http://www.cypress.com/?rID=101641
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/cy8ckit-042
http://www.cypress.com/CY8CKIT-040
http://www.cypress.com/CY8CKIT-049
http://www.cypress.com/go/CY8CKIT-001
http://www.cypress.com/go/cy8ckit-002
http://www.cypress.com/knowledge-base-search
http://www.cypress.com/?id=4&rID=98796
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Þ PSoC Creator Training: Visit www.cypress.com/training for a comprehensive list of video trainings on PSoC Creator. 

Þ Learning from Peers: Visit www.cypress.com/forums to meet enthusiastic PSoC developers discussing the next 
generation embedded systems on Cypress Developer Community Forums. 

1.6   Technical Support 

For assistance, visit Cypress Support or contact customer support at +1(800) 541-4736 Ext. 3 (in the USA) or +1 (408) 943-
2600 Ext. 3 (International). 

1.7   Document Conventions 

Table 1-1. Document Conventions for Guides 

Convention Usage 

Courier New  Displays file locations, user-entered text, and source code: 
C: \  ...cd \ icc \  

Italics Displays file names and reference documentation: 

Read about the sourcefile.hex file in the PSoC Creator User Guide. 

[Bracketed, Bold] Displays keyboard commands in procedures: 

[Enter] or [Ctrl] [C] 

File > Open Represents menu paths: 

File > Open > New Project 

Bold Displays commands, menu paths, and icon names in procedures: 

Click the File icon and then click Open. 

Times New Roman Displays an equation: 

2 + 2 = 4 

Text in gray boxes Describes Cautions or unique functionality of the product. 

 

http://www.cypress.com/training
http://www.cypress.com/forums
http://www.cypress.com/support
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1.8   Acronyms 

Table 1-2. Acronyms Used in this Document 

Acronym Description 

ADC Analog-to-Digital Converter 

ESD Electrostatic Discharge 

F-RAM Ferroelectric Random Access Memory 

GPIO General Purpose Input/Output 

I2C Inter-Integrated Circuit 

IDE Integrated Development Environment 

ILO Internal Low-speed Oscillator 

IMO Internal Main Oscillator 

LDO Low Drop Out (voltage regulator) 

LED Light-Emitting Diode 

LFCLK Low-frequency Clock 

LSB Least Significant Byte 

MSB Most Significant Byte 

PSoC Programmable Systems-on-Chip 

PWM Pulse Width Modulation 

RGB Red Green Blue 

SAR Successive Approximation Register 

SPI Serial Peripheral Interface 

SWD Serial Wire Debug 

UART Universal Asynchronous Receiver Transmitter 

USB Universal Serial Bus 
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2.   Installation 

 

This chapter describes the steps to install the software tools and packages on a PC for using the CY8CKIT-044 PSoC 4 M-
Series Pioneer Kit. This includes the IDE on which the projects will be built and used for programming. 

2.1   Before You Begin 

To install Cypress software, you will require administrator privileges. However, they are not required to run the software that 
is already installed. Before you install the kit software, close any other Cypress software that is currently running. 

2.2   Install Software 

Follow these steps to install the CY8CKIT-044 PSoC 4 M-Series Pioneer Kit software: 

1. Download the PSoC 4 M-Series Pioneer Kit software from www.cypress.com/CY8CKIT-044. The kit software is 
available in three different formats for download. 

a. CY8CKIT-044 Kit Complete Setup: This installation package contains the files related to the kit. However, it 
does not include the Windows Installer or Microsoft .NET framework packages. If these packages are not on 
your computer, the installer directs you to download and install them from the Internet. 

b. CY8CKIT-044 Kit Only: This executable file installs only the kit contents, which include kit code examples, 
hardware files, and user documents. This package can be used if all the software prerequisites (listed in step 
5) are installed on your PC. 

c. CY8CKIT-044 DVD ISO: This file is a complete package, stored in a DVD-ROM image format, which you can 
use to create a DVD or extract using an ISO extraction program such as WinZip® or WinRAR. The file can 
also be mounted like a virtual CD/DVD using virtual drive programs such as Virtual CloneDrive and MagicISO. 
This file includes all the required software, utilities, drivers, hardware files, and user documents. 

2. If you have downloaded the ISO file, mount it in a virtual drive. Extract the ISO contents if you do not have a virtual 
drive to mount. Double-click cyautorun.exe in the root directory of the extracted content or the mounted ISO if ñAutorun 
from CD/DVDò is not enabled on the PC. The installation window will appear automatically.  

Note: If you are using the ñKit Complete Setupò or ñKit Onlyò file, then go to step 4 for installation. 

3. Click Install CY8CKIT-044 to start the kit installation, as shown in Figure 2-1. 

http://www.cypress.com/CY8CKIT-044
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Figure 2-1. Kit Installer Screen 

 

 

4. Select the folder in which you want to install the CY8CKIT-044 kit-related files. Choose the directory and click Next. 

5. When you click Next, the CY8CKIT-044 installer automatically installs the required software, if it is not present on your 
computer. Following is the required software: 

a. PSoC Creator 4.2: This software is available for download separately at www.cypress.com/psoccreator.  
PSoC Creator 4.2 installer automatically installs the following additional software: 

- PSoC Programmer 3.27.1 

- Peripheral Driver Library 3.0.1 

6. Choose the Typical/Custom/Complete installation type in the Product Installation Overview window, as shown in 
Figure 2-2. Click Next after you select the installation type. 

http://www.cypress.com/psoccreator
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Figure 2-2. Product Installation Overview 

 

7. Read the License agreement and select I accept the terms in the license agreement to continue with installation. 
Click Next. 

8. When the installation begins, a list of packages appears on the installation page. A green check mark appears next to 
each package after successful installation. 

9. Enter your contact information or select the check box Continue Without Contact Information. Click Finish to 
complete the CY8CKIT-044 kit software installation. 

10. After the installation is complete, the kit contents are available at the following location: 

<Install_Directory> \ CY8CKIT- 044 PSoC 4 M - Series Pioneer  Kit  

Default location:  

Windows 7 (64-bit): C: \ Program Files (x86) \ Cypress \ CY8CKIT- 044 PSoC 4 M - Series Pioneer  Kit  

Windows 7 (32-bit): C: \ Program Files \ Cypress \ CY8CKIT- 044 PSoC 4 M - Series Pioneer  Kit  

Note: For Windows 7/8/8.1/10 users, the installed files and the folder are read only. To use the installed code examples, 
follow the steps outlined in the Code Examples chapter. These steps will create an editable copy of the example in a path 
that you choose so the original installed example is not modified. 

2.3   Uninstall Software 
The software can be uninstalled using one of the following methods: 

Þ Go to Start > All Programs > Cypress > Cypress Update Manager and select the Uninstall button that corresponds 
to the kit software. 

Þ Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove Programs for Windows XP; 
select the Uninstall/Change button. 
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3.   Kit Operation 

 

This chapter introduces you to the PSoC 4 M-Series Pioneer Kit features. 

3.1   Theory of Operation 

The PSoC 4 M-Series Pioneer Kit is built around the PSoC 4200M device. Figure 3-1 shows the block diagram of the 
PSoC 4200M device. Refer to the PSoC 4200M datasheet for details on the device features. 

Figure 3-1. PSoC 4200M Block Diagram 






























































































