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Chapter 1. Getting Started 
Introduction to DesignSpark PRO 
Welcome to the DesignSpark PRO Schematic and PCB design system. The system is built on an integrated design 
environment providing all the tools required to capture a schematic, output it to Spice simulation and pass it 
through to the PCB design environment for the printed circuit boards (PCBs). The PCB design process is aided with a 
shape-based autorouter. Outputs to industry  

System Requirements 
The table below shows the hardware requirements for running DesignSpark PRO. It shows both the minimum and 
the recommended specification. It should be said that this product will run pretty much on any off-the-shelf PC 
available in most computer stores.  

Recommendation 

Processor Pentium i5 or better, such as i7 

RAM 2048MB or more 

Hard disk space 650Mb for product 

Operating System Windows 10 

Graphics Better than 1024x768 

Mouse Wheel Mouse 
* MAC O/S or Linux are not supported. All supported operating systems are supported in both 32 and 64 bit
formats. Please visit our web site for the latest news on supported operating systems. 

Installation 
It is assumed that you have successfully installed the DesignSpark PRO product or demo onto your computer. If you 
haven’t, then use the product CD or a download from the numberone.com web site. The installation is straight 
forward using the wizard provided. Follow the instructions and use the default settings provided. The tutorial 
designs can be run even using DesignSpark PRO in demo mode if the demonstration version is being used. Note, the 
demo version and full product are not the same, the demo cannot be ‘converted’ to a full version, it requires a new 
installation. 

Introduction to the Tutorial 
You can quickly familiarise yourself with the DesignSpark PRO features available and its design methodology by 
working your way through this tutorial and using the Online Help for more detail. This tutorial is broken down into 
logical sections following a typical Schematic to PCB design cycle. This tutorial can be used with both the full 
purchased product and the trial alike. 

The Schematic design editor is used to capture your logical design and ‘drive’ the PCB design. However, the PCB 
design editor can be used with or without the schematic design as you wish. An important aspect of the PCB design 
is the production of professional manufacturing data, and hence the final PCB. DesignSpark PRO has outputs to 
Gerber 274-D and 274-X (with the embedded apertures), NC Drill, pen plotter, full Windows printer support, PDF, 
ODB++, Bill-of-materials, netlists, DXF and IDF formats. Assembly machine outputs for pick & place machines and 
suchlike can also be output. 

Additional Help and Information 
There are many more exciting aspects to DesignSpark PRO which are not covered in this document. Further 
information can be obtained in the Online Help by pressing the <F1> key on your keyboard at any time, or by 
reading the DesignSpark PRO Users Guide. You can also obtain additional information by viewing the FAQs on the 
DesignSpark web site. 
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Starting DesignSpark PRO 
During installation, an DesignSpark PRO program group added to the Start menu, under 
Programs then DesignSpark>. 

Select the DesignSpark PRO menu item to start the program. 

The DesignSpark PRO Desktop 
When you run DesignSpark PRO, the main application window appears. You can open any number and combination 
of different designs and libraries together in this. DesignSpark PRO is broken down into many facets as are most 
Windows applications. The picture below shows you the major framework facets by name so that as they are used 
in this tutorial you will understand what is being talked about. 
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Toolbars 
DesignSpark PRO is installed with a set of commonly used toolbars for you to use. These tools can be fully 
customised to suit your own design practice once you become familiar with the product. 

If you hover the mouse over the toolbar buttons a small tooltip 
is displayed showing the button function and its keyboard 
shortcut if one has been defined. 

Customising DesignSpark PRO 
DesignSpark PRO provides you with the ability to customise the user interface with your own Toolbars, menus and 
keyboard commands. You also have a complete command set of all the options within DesignSpark PRO which can 
be assigned to a shortcut key on the keyboard. Other aspects of DesignSpark PRO can be customised using the 
Customise option on the Settings menu. 

Commands and Shortcuts 
As well as the toolbars, DesignSpark PRO has the ability for you to programme your keyboard for commonly used 
options or commands. This means that once programmed, you can press a key or combinations of keys to enter a 
function or option. For experienced users, this makes the program's operation far more efficient. 

When DesignSpark PRO is first installed, you will find a set of shortcuts already defined for you. These are only a 
default set and can be modified to your own preference through the Keyboard tab on the Customise dialog. Almost 
all of the keys on a standard keyboard can be utilised giving you extensive coverage. 

A full report of all the assigned keys can be obtained from this dialog using the Shortcut Report button on the 
Keyboard tab. 

Cancelling Commands 
All dialogs and commands can be exited at any time by clicking the <ESC> key on the keyboard. Sometimes this will 
need to be pressed a couple of times if you are ‘down’ in a sub-menu or lower-level option. 

Units 
The Units option on the Settings menu is used to define the units and the precision at which the co-ordinates and 
lengths displayed in the dialogs and edited by you are displayed. The basic working units can be changed between 
Imperial and Metric design units. You can quickly toggle between Metric and Imperial units by using the Switch 
Units button on this dialog or by clicking the shortcut Shift-I when working in the design. 

The design units are stored in an internal 
database with a precision of 1/100 micron 
regardless of what the unit precision is set to. 

For each type of units, you can specify a 
precision. This is the number of decimal places 
displayed; the value is simply rounded to the 
nearest last digit. 
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Grids 
Grids are used in DesignSpark PRO for defining the points or steps that items will snap to when they are placed and 
for visible references in the design. For this, the Grids dialog on the Settings menu can contain any number of 
named grids:  

The Grids area will allow you to define the 
grid used for placement of design items 
during manual interaction.  

Grids can be defined as regular X Y grids or 
polar (radial) grids. 

They can be referenced relative to the 
Coordinate Origin. 

The Visible check box enables the grids to be 
displayed on or off, this can be set at any 
time in the design using the shortcut key <G>. 

The Display area is used to define the display 
of 'dots' or ‘line’ to guide you while designing. 
Size Steps: is used to define the ‘pitch’ of the 
grid and uses the Secondary Colour to display 
them. The Primary Colour is used to display 
another grid based on a 10 times larger size 
than the Secondary Grid. 

Snapping to Grid 

The Snap Mode shortcut can be displayed during editing by selecting the direct keyboard command <Ctrl-G>. By 
selecting the snap mode setting you can use predefined multiples of the Working Grid to move items for example. 



8   Chapter 1 – Getting Started 

Shortcut Menus 
The right hand mouse button can be used extensively throughout DesignSpark PRO to display shortcut menus, 
these are also known as context menus. These menus can be accessed during an operation and contain a set of 
relevant 'context' commands. 

Once familiar with the system, you can access the shortcut menus by right clicking directly on the item and picking 
the option from the menu. 

 

Undo/Redo 
DesignSpark PRO contains unlimited multi-level Undo and Redo capabilities for use through the product.  These are 
invoked using the standard Windows shortcut keys Ctrl-Z and Ctrl-Y respectively, these are also available on the Edit 
menu and as toolbar icons. 

Properties of items 
Each item in the design contains a set of characteristics that can be viewed or edited using the Properties option. 
Some items within the design are made up of several entities, each of which is individually selectable and has its 
own properties that can be viewed, components for example. 

 

Design item properties can be viewed by 
selecting the item and clicking on the 
Properties option from the shortcut menu. It is 
quicker though to select the item and click the 
shortcut key Alt-Enter. The example left shows 
the Pad properties of a component pad. 
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Status Bar 
The status bar at the bottom of the design window displays useful information about the design item selected. 
When using an option, like track editing, it also provides you with a command prompt to show you what action is 
expected. More detailed information is also available by selecting the design item and using the Properties dialog. 

 

Design tooltips 
As well as the status bar information and Properties dialog, by hovering the mouse over a design item, information 
about that item will be instantly revealed on a design tooltip. 

 

Dockable Windows and Browsers 
As part of the design suite, you have a number of dockable windows and browsers that can be used.  

Each individual window can be specified to Allow Docking (enabled through the shortcut menu for each window or 
browser).  

 

These windows are available through the View menu 
Dockable Bars > 
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Chapter 2. Creating The Schematic 
Schematic Design Tutorial 
During the tutorial we will create a Schematic design, this is how the engineer ‘conceived’ it:  

 
Obviously, once the sketch has been drawn properly as a DesignSpark PRO Schematic it will look quite a bit 
different. 

Starting a New Schematic 

u To start a new Schematic design 
On the File menu, click New and Schematic Design from the Design tab. 

 
Under Using Technology File, for the Name: click on the small 'down' arrow to reveal the drop down list, select 
Default.stf More detail about Technology files is available in the Online Help. 

Leave the Add To Project box unchecked. We will create a simple single schematic sheet without a project for this 
exercise. 

Click the OK button to start a new Schematic design. 
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Your DesignSpark PRO window will look like this, you’ll notice there is already a design prepared for you to view in 
program called ChipKIT Max32.prj 

 
For now, we will progress on to adding components to the design. 

Adding Components 
You can use two methods to add components; by using the Add Component option and using the Add Component 
Browser. For this tutorial, we will use the Add Component Browser. 

For our tutorial we will enable more libraries. For simplicity, the standard DesignSpark PRO installation only enables 
a small selection of libraries to start with. 

u To enable more libraries 
From the Setup menu, choose Folders. Click on the Libraries tab. 

You need to enable the folder at the bottom of the Folders list - \Library  

It is greyed out currently (not enabled), select it and press the Folder Enabled check box. 
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You will now see more libraries have been enabled in the contents list. 

Press OK to confirm the selection and exit.  

u To add a Component
The Add Component Browser bar has automatically been run when you started a new Schematic design.

Hover your cursor over the Add Component Browser 

The browser will ‘slide’ out. It will collect the first library which will be 
‘User’. Of course, User is still empty as it is supplied as a template to add 
your own library contents to. 

From the list of Libraries, which currently shows User, select the small ‘down’ arrow to reveal the full list of libraries. 

The list displays all the libraries enabled. 

From the list, choose discrete You may have to scroll down 
to see the name. 

The Component list will now be populated with 
components from that library. The first component found 
in the library will be automatically displayed. 

From the list, select the component R, this will be a resisotor. Either scroll down using the slider bar or pick in the 
list and type R, the list will then automatically scroll down to the first component starting with the letter R.  
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This is a generic resistor with no specific value now, we will change the Value for later on. 

For now, we will only use generic components from the standard library and not worry about them having RS part 
numbers, availability, cost etc. 

 

A preview of both the Schematic and PCB symbols is displayed. 

Once you have the correct component, you can add it to the 
design by selecting either of the symbol previews and dragging it 
into the design. You can also add it by selecting its name (R) and 
dragging it into the design. 

This is a one-shot process. If you wish to add more components 
you must drag them from the bin or copy an existing one in the 
design. 

 

The component is currently on the end of your cursor. To place it in the design click the left mouse button once.  

You need three resistors in total for the final circuit. Once the first one has been placed you can copy it two more 
times. Select the resistor R1 in the design. Hold down the Ctrl key on your keyboard at the same time as ‘dragging’ 
the mouse away from the resistor. As you drag you will see that an identical copy of R1 has been made and is 
named R2. 

Copy the resistor one more time to add a total of three. 

Position them to look like this: 

 

u To pan & zoom in the design 
To view the resistor closer, roll the mouse wheel button forward to zoom in. If you zoom in too fast (and too far), 
roll the mouse wheel button backwards (slowly). If you zoom too far either way, press A on the keyboard to View 
All and then zoom in again. Shortcut keys are also available for Zoon in and Zoom out. 
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u To add the capacitors 
We need four capacitors for this circuit. From the Add Component Browser option type C in the list. The 
component name will jump back to the C component from the list. 

 

Pick and drag one component from the browser to the design to add it. 

 

Just the one capacitor will be added. 

We will use a different technique to add more capacitors. 

Select the capacitor C1 in the design.  

The standard Windows commands of Ctrl-C (Copy) and Ctrl-V (Paste) can be used to add 
components by copying them. You can also use the DesignSpark PRO command Duplicate <D> to 
make copies. 

Select C1 and press Ctrl-C to copy it. Now press Ctrl-V to paste a copy (now called C2) back into the 
design. 

 
Because the capacitor is in the paste buffer, you can add more of the same capacitor. 
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Move C2 away just underneath C1 by moving the mouse. Single click to release. Now do the same again, this time to 
C2 to add another capacitor C3 and then again to C3 to add C4.  

Your design now looks like this: 

 

u To switch off the displayed grid 
At this stage we don’t really need to see the displayed grid dots so let’s switch them off. Click <G> to toggle the grid 
off. Press this key again will switch it back on at any time. 

u To add the Op-Amp 
We will now add an Op-Amp. This time, click the Add Component button on the toolbar, shortcut <F8>. 

 
The Add Component dialog will display the discrete.cml library that you’ve already been using with the Add 
Component browser. We need to swap libraries to another one. Click the small ‘down’ arrow to reveal the fully 
libraries listing. 

 
From the list, select the Opamps library. 

In the Component: list, type in AD844, this will jump down to the name AD844AN on the list. This is the DIP8 
version of this device but for this exercise it isn’t important. 
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This time we will place the component into the Component Bin and not directly into the design to show you 
another mechanism for adding components to the design. 

Before adding it to the design, roll the mouse wheel to zoom out. You will need to give yourself some space on the 
design in which to place this new component. 

Check the Add to Component Bin check box on the dialog and ensure Count: is set to 1. Click the Add button once 
then click the Close button to exit this option. 

 
To display the contents of the Component Bin, move your cursor to the right side of the DesignSpark PRO window 
over the Component Bin tab. Hover the cursor to reveal the Bin. Moving the cursor away will slide the window back 
in to close it. 

 
Our Op-Amp (U1) is shown in the Bin as two gates (Gate a & Gate b). Click on Gate a under the word U1 – AD844AN 
{DIP8} to see a preview of the symbol above it. 

Select Gate a and drag it into the design (pick and drag at the same time). Position it near the capacitors. Now go 
back to the Component Bin (hover the cursor over the Component Bin tab). Drag Gate b from the bin. This is the 
Op-Amp power gate. Drag it into the design, it can go anywhere and can be moved later on. 
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Your design should look something like this: 

Before we make the connections, we should change the component values to be the ones required. This is easy to 
do because we’ve used ‘generic’ components. If you prefer to use specific Parts, you can also work this way with 
DesignSpark PRO. 

u To edit component Values
Double-click on the Value field (1K) and the Text tab of the Properties dialog is displayed. Click on the Component 
Values tab.  

The Value field shows the current 1K value and is already highlighted blue. Simply click the Edit button or double-
click the blue highlighted field to edit the value required. Type in 11K. 
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When done, click the OK button to exit this dialog and OK again to exit Properties. When the value of R2 is changed 
to 11K the design is updated. 

Using the same process (double-clicking on the Value name), edit the Value fields for all R’s and C’s in the design as 
shown below: 

R1 1K R2 11K R3 1.6K 

C1 68n C2 200n C3 0.22u C4 0.22u 

Our design now looks like this: 

If you select the whole component by mistake, you can still edit the Value field by clicking Component Values tab 
on the Properties dialog. 

u To save the design
At this stage it might be a good idea to save your design. If you are using the evaluation tutorial with DesignSpark 
PRO in demo mode, you will not be able to save the design. If you have installed the purchased product go to the 
File menu and Save As. Save it somewhere you can find it later on if needed and call it something sensible, like 
Tutorial.sch. 



 Chapter 2 – Schematic Capture Editor   19 

Placing Components 
The position of the components currently is as they were placed after adding them to the design. We need to place 
them around the Op-Amp so they can be used in our circuit. On a real design, this would be how you would work in 
practice. To remind you, the original ‘drawn’ circuit looks like this: 

 
As before, move the components into position by picking and dragging them in one move using the mouse. 

Components can be rotated during move by clicking the R key (while using pick-drag). A single click of the R key will 
rotate the component by 90 degrees. Click R more than once to rotate it by another 90 degrees and so on. 

You can also change the placement to fine tune it after adding the connections as well. 

The design will now be looking like this: 

 
You are now ready to add connections. 

Adding Connections 
Connections are added to the Schematic design to make connectivity between electrical pins. When translated to 
the PCB design, these connections give you your net list. 

By adding a connection when you start this tutorial, default properties are already set up. All you need to do is add 
the connection. Later on as you become more familiar with DesignSpark PRO, you can change and customise the 
connection properties to your own settings. 

You can add connections in a number of ways: 

· Using the Add Connection option from the Add menu or from the Schematic Toolbar, click on 
the pin to start adding a connection, or; 

· Double-clicking on a component pin to start a new connection, or; 
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· 'Dragging' off an unconnected component pin to start a new connection. 

For this tutorial we will use the ‘dragging off pins’ method as this is the easiest to start with. 

u To add connections by dragging off pins 
To aid the addition of connections to a schematic, you can simply ‘drag’ off an electrical pin. Each click of the mouse 
will then add a corner, moving over another electrical pin will show a finish marker; a small illuminated blob over 
the pin. This shows the item as a legal landing site to finish the connection. 

Using the design that you have created so far, zoom in on the area around R1 like the picture below. 

 
When you hover the mouse over the right hand terminal of the resistor R1 a small design tooltip label is displayed. 
This confirms the name of the device and the pin number (R1-2). Although on this resistor it is a bit excessive, on a 
BGA pin which has a connection and net name, it becomes very useful (and essential!). These design tooltips are 
available for all designs items, not just pins. 

Click and drag (keeping the mouse button pressed down) off pin 2 of R1, this will start a new connection. 

Move the mouse over U1 pin 2. 

You’ll now see a finish indicator with a small solid circle on it. This indicates that the connection can legally be 
finished here. 

 
You do not have to be exactly over a pin for the finish marker to be displayed, as long as the cursor is within range 
then it will be shown.  

Click the mouse button once to finish. You’ll notice that the component pin terminals X disappear when you 
connect to it, this indicates that it is connected. 

Following our ‘sketched’ design, complete the connections in the design. 

u To join connections together 
There are a couple of connections which must be connected together. Let’s assume that you’ve made a connection 
and now you need to connect another to it using a junction dot. 

When you move over the existing connection and hover momentarily, a finish marker will be displayed. Click to 
release the connection here and this net is now connected to the one already there.  A junction dot will 
automatically be added to show the connections are connected. 

Complete the design adding the connections required. 

Adding Power & Ground Symbols 
Power and ground symbols are used in the Schematic to indicate a connection to a power source. These symbols 
are required for aesthetic purposes and are not translated to the PCB (because they do not have PCB footprints 
associated with them). The signals they represent are connected together at the translate stage by ‘implied’ 
connectivity. The power & ground symbols themselves can contain inherent net name properties that are 
automatically used when the symbol is attached to the net. 
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u To add Power symbols 
Click on the Add Component icon on the toolbar. 

 
In the Library: drop down list, select the Schema library. Any selected symbols will be previewed as being Schematic 
symbol with no PCB footprint.  

In the Component: list select 0V. You will see the symbol selected in the Preview box. 

Ensure the Add to Component Bin check box is unchecked, click the Add button. 

The 0V symbol is on the end of your cursor. Move it near to C4 and click the mouse once to release it. 

 
Using our working design, add two more 0V symbols, then click the <ESC> key to cancel. Select the Add Component 
option again. 

Our original design is shown below. Your component names may differ slightly, it doesn’t matter, their relative 
position and values are more important. 

 
Add one +15V symbol and place near C3, then <ESC> again. Now add one -15V symbol, place near C4. Click <ESC> to 
exit. 
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Drag a connection off the end of the symbols and connected as shown below. Move the power gate for U1b to the 
position shown below just under C4. 

Your design will look something like this: 

 
Generally speaking, you would now need to add some connector pins to connect the circuit to the outside world. 

Adding Connectors 
For this example, we will use an existing connector component from the library. 

u To add Connector pins  
Click on the Add Component option from the toolbar. 

 
From the dialog, select the Library: Connector from the list. In the Component: list select the 5WP connector, this 
will be shown in the preview windows along with it’s PCB Footprint. It will be automatically named PL1. 
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Click the Add button to add it to the design, place it near the resistor R1. Click the <ESC> key to cancel Add 
Component. If it comes in mirrored to what is shown here, mirror it back using <F> Flip. 

Connect in the connector to the design using Add Connection or by dragging off pin. You will also need to add 
another +15 component for completeness. Your design should look like this below: 

Click the Save button on the File menu to save the design. If you are using the tutorial in demo mode you cannot 
save it. 

Naming Connections 
One last task that is often required is that of naming connections in the design. We’ve added ‘normal’ connections 
which have been named using the default naming convention and have been given ‘system’ names like N0005, 
N0100, N008 etc. We’ve also added connections between pins and components that have pre-defined net names 
(power and ground components, +5V, 0V etc.). 

We now need to name a few connections to make them more specific for use in the PCB design. 

u To edit net names
Select the connection just off pin 7 of the Op-Amp’s power gate, the gate marked as U1b.
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Right click and from the shortcut menu, select Change Net. If you use this a lot, you can assign it to a shortcut key. 

 
From the dialog now displayed, select the Net Name: +15V from the list. 

From the Net Class: list, select Power. This will pre-assign you a set of connection properties for this net when it 
gets used in the PCB portion of the design. 

 
Click OK and return to the design. 

If you wish to see the Net Name in the design, right click again with the connection selected and choose Display Net 
Name from the menu (this is the option just above the previously used Change Net option). The net name will now 
be displayed in the design, you may reposition it if required by picking and dragging it. 

Change net name on the power gate 

u Change net name on the power gate  
Now select pin 4 on U1b. Using Change Net again, this time select the net name -15V. Select the Power Net Class 
again. Click OK to exit this dialog. Do the same with pin 7 on U1b and make this 0V The Net Name can be displayed 
using the method above if required. 
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Translating the Schematic to PCB 
The final process before starting on the PCB design itself is to translate the Schematic design into the PCB design 
environment.  

When you are in a position where you wish to go-ahead with this translation you should use the Translate To PCB 
option from the Tools menu. This is discussed in the following pages in the PCB Design section. Select this option 
now to carry on. 

 
Type in a PCB Design: name, for example Tutorial 

Select a Technology File to be used for the PCB design. Use the Double Sided technology file. This will give you a 
basic double sided design. 

Check the Use Component Bin box. Click OK to translate the components and netlist to a PCB design. 

The PCB design editor will run up. All of your PCB footprint components will be in the Component Bin, the design 
will initially appear empty, don’t be alarmed this is normal! 

Schematic Design Completed 
You have now completed the first section of this introductory tutorial so let’s move on. Leave everything as it is and 
read on if you wish to continue with the PCB design tutorial. 
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Chapter 3. PCB Design Editor 
Getting Started with the Design 
DesignSpark PRO PCB is flexible in that you can start your layout in a number of ways: 

· Use DesignSpark PRO Schematic Capture as the 'front-end' to the PCB system. The nets and 
components are translated to PCB in the integrated environment. 

· Use a netlist that is derived from another CAE or Schematic system. 

· Use the DesignSpark PRO PCB design editor interactively creating the design on-the-fly without 
the need for an initial netlist. You just add connections and components as required to create 
the PCB design. 

Translate to PCB 
We will take the ‘logical’ Schematic design created in the previous section and convert it to a ‘physical’ PCB layout. 

You can skip this bit if you have already translated your design, go onto Setting up a PCB Technology below. If you 
need to translate the Schematic to PCB - from in the Schematic design editor with our tutorial design, select the 
Translate to PCB option from the Tools menu. 

 
Type in a PCB Design: name – Tutorial (no file extension is required, just the name). 

Under Technology File, choose Double Sided to be used for the PCB design. The Technology predefines ‘rules’, such 
as the layers, pad styles, track styles, colours and other aspects of the ‘make-up’ of the overall PCB design. 
Technology files make the initial set-up of a design much quicker but you can modify all aspects of this during the 
design stage. 

Select the Use Components Bin box, the Translate option will put our components into an off-page location for 
clarity for now.  

Click OK to convert the components and netlist to a PCB design. Your design will appear blank, all the components 
are ready to place in the Component bin which is not visible. 

At this point you are ready to start laying out the PCB design. 

Setting up a PCB Technology 
When choosing or setting up a Technology file in your design you must think ahead and think about the final 
manufacturing process and whether your manufacturer can handle it. The technology used by you can have an 
impact on the cost of the final PCB. Changing your track styles from 8 to 6 thou for example, or adding blind and 
buried vias could have significant costs implications. You should always check that the boards can actually be 
manufactured. 

All aspects of the technology can be edited and added to as you go, this includes the number of layers in the design, 
styles and names etc. 

For this exercise, you will use a pre-defined technology file, Double Sided. This provides you with a two-layer PCB 
with a set of general purpose styles and sizes. It also uses a black background; this can be easily changed if you 
prefer a lighter colour background such as white or light grey which seems to be easier on the eyes. 

Layers 
The DesignSpark PRO PCB design system supports an unlimited number of layers in any combination of Electrical, 
Non-electrical, Wire, Construction and Documentation layers. These layers are used to detail the physical 'make-up' 
of the manufactured PCB. 
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Below is an illustration of a typical 4 layer PCB showing the 4 electrical layers, 2 outer layers - Top and Bottom and 
the inner power plane layers - Ground and Power. 

If you wish to view the layers dialog, from the Settings menu select Layers. Click OK to close the dialog once you’ve 
viewed it. 

Creating a Board Outline Interactively 
Board outlines can be created easily in DesignSpark PRO; by adding board shapes (including circles) or by importing 
DXF files from your mechanical system which contain board outlines. 

Add Board allows you to interactively create a board outline by drawing it into the design. Three shape styles are 
provided: Rectangle, Circle and Polygon. 

u To insert a board outline
On the Add menu, click Board> Rectangle.

This is the shape you will create; the overall length is 1900 thou and the height is 1300 thou: 

With Add Board selected, in the design area right click and select Type Coordinate from the context menu. On the 
dialog, type 2000 X and 2000 Y, then click OK. This starts the shape. 
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Now right click again and from the context menu, select Type Offset. On the dialog, type 1750 X and 1300 Y, then 
click OK. 

 
Your board will look like this so far: 

 
Click the mouse once to add the corner at the top right side. 

Drag the corner down so that a 90 degree corner is formed and the remaining two sides are straight. Double-click to 
finish. 

 
Once a board outline has been added, it can be modified afterwards, extra segments added and the corners can 
even be mitred or curved. 

 

 

 

 

 

Add the ‘notch’ now. Double-click on the right 
side to insert a corner. Move the cursor right 
150 thou and up 250 thou. Single click to add 
the first corner. 

 

 

 

Move the cursor up 800 thou.  Single click to 
add a corner. 
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Move the cursor left so that the two remaining 
floating segments are at right angles to each 
other. 

 

 

 

 

Double-click to finish. 

Our board outline is finished. 

 

 

 

We now need to place the components in our design. 

Using the Component Bin 
While we’ve been starting the design with the board outline and preparing the technology, our components have 
been sat in an off-design location waiting to be placed. During the Translate To PCB stage, we checked the box on 
the dialog to place the components in the Component Bin. There are other ways to work, such as placing unplaced 
components around the board outline or placing them in a ‘pile’. We now need to open the Component Bin and 
place the components in the design. 

From the right side of the DesignSpark PRO design edge (called the framework), you can hover your cursor over the 
tab Component Bin 

     
This will display the components that were sent to the bin. 

When opened it 
looks like this 
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u To drag Components from the bin 
You can select a component from the Bin or the Preview window. To use a component, ‘drag and drop’ it into the 
design (pick it and while picking, drag it into place). 

Note: during place the drag may be cancelled by dropping the component back into the Bin, by pressing the <ESC> 
key, or once released by using Undo (Ctrl-Z). 

Once in the design the component can be moved until released, again by picking and dragging. 

The following PCB images have now had their backgrounds changed to be white to make them stand out more 
clearly on paper. You are free to use a black background or any other colour of your choosing. 

Place all the components to look like the picture below. It is suggested you place PL1 and U1 first and place the 
other components around these. Placement on this design isn’t critical but if you can improve on it, do it. 

 

Moving Components  
Once the Components have been dragged from the bin you can place them in the design. While placing 
components, use the shortcut key R to Rotate them and F to Flip (mirror) surface mount components, these options 
(and more) are available on the shortcut menu during Place by clicking the right mouse button. 

 
For our design, no mirroring (Flip) will be required. The placement and overall connection lengths could be 
improved by rotating some of the components. If you feel you would like the practice placing components, select a 
component and click R to rotate it. Component names can be rotated back to be a readable direction separately 
using the same pick and rotate method. 

Once fully placed, the design should be routed. 

Save the design at this point using the File menu | Save option. 
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Routing the Design 
The design can be routed manually or automatically. This is the process of converting the electrical point-to-point 
connections into physical copper ‘tracks’. 

Initially we will route the design manually. DesignSpark PRO has a set of powerful manual routing tools to aid this 
process. These tools allow you to swap layers, automatically add vias on layer swaps and edit track thickness.  

The routed board might look something like this (we’ve changed the colours to make the design easier to view in 
this tutorial): 

 

u To start routing tracks manually 
To start adding tracks, double-click on a connection, this is the quickest method to start routing, other methods are 
available. 

 

Hover the cursor over the connection to reveal the 
design tooltip. This will tell you that you have 
selected the correct connection. 

If you followed our design placement loosely, double-
click the connection between R3 and C1. 

 

Once started, move the cursor to the left slightly. 
You’ll see the track starting to take shape and a 
connection between the end of the track and the 
‘target’ pad (on C1).  

 

 

 

If you right click once routing has started, you can 
select Segment Mode> from the menu. From the sub-
menu, you can choose how you wish to route the 
board. It is normal to use Orthogonal mode (two 
floating segments at 90-degrees) or Mitre mode. 
Mitre mode is our preference and used for this 
tutorial. This will route with a 45-degree angle on the 
second floating segment. 
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Click the mouse once, this places the first track 
segment, then move the cursor up slightly. You’ll see 
the 45-degree track segment, click the mouse again. 

If at any point you make a mistake, use the 
<Backspace> key to delete the previous segment back 
to the last corner. You can do this while still in ‘edit’ 
mode. 

 

 

Now we will add a track layer change. 

Press the ‘L’ key on the keyboard and the Change 
Layer dialog is displayed. During normal routing 
where a layer change from one side to the other is 
required, a simple ‘L’ followed by <Enter> is all that is 
required. The Enter button is the same as clicking OK 
on the dialog. In time you will be able to change 
layers without looking at the dialog. 

 

A via has been added automatically and the track 
layer is now on the Bottom side and is shown in a 
different colour (blue). 

Move the cursor left and up slightly. This will either 
be the next corner or the next location for a via for a 
layer change. Click the mouse to release a corner. 

Obviously, this is a bit unrealistic because we could 
just route it on the same layer. 

 

Press ‘L’ and <Enter> again to change layers back to 
the Top side. Another via is added automatically.  The 
via and track sizes are taken from the net class, this is 
set up as part of your Technology file. 

Notice how the tracks and pads on the top layer have 
changed colour to indicate you are routing on the 
other side. 

 

Move the cursor up towards the target C1. Notice 
how it is on the Top layer again and shown in Red. 

Move the cursor (with track) over the target pad. 
When a legal landing site is available, the cursor 
changes to a finish marker, a highlighted ‘blob’. 

 

Click once to finish the track editing for this 
connection. After the track has been added, it can 
always be modified afterwards by picking and 
dragging the track or by double-clicking on the track 
to edit it. 

Move onto the next connection for editing.  

Summary of the basic modes of routing 

During track editing, the basic commands for use are:  

· Single-Click, once editing, this will insert a corner to change routing direction. 

· <L> followed by <Enter> will enable a layer change to the opposite side of the design. This can 
be used during editing, or afterwards on selection of a track. 
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Picking in tight areas 
When attempting to select items within a dense area of the design or where multiple connections cross each other 
for example, it is not always easy to pick the item required at the first attempt. Under these circumstances 
DesignSpark PRO has a system of picking that 'cycles' through items adjacent to it until you select the item required. 
Once selected, an action may be made on that item, Properties for example. 

The shortcut keys used for the commands Select Next and Select Previous are set up as N for Next and P for 
Previous, these can be changed if you wish to. 

To try this, click on a pad that has a track attached to it, the pad (or track) is selected. Now click N and the track (or 
pad) will be selected. Depending on how close it is to other design items, the component outline and the whole 
component may also be selected at each click of N is made. 

Unrouting Tracks 
You may sometimes have a requirement to unroute all or part of the design. Unrouting is the process of removing 
tracks leaving only the connections remaining. 

The Unroute Nets> option is available on the Tools menu, the three options available to control the amount of 
unrouting to perform. 

Try using the Unroute Nets> All Nets option to unroute the whole design removing all the tracks already done. For 
the next section we will use the autorouter to re-route the design. Don’t forget, once unrouted, you can always 
restore the routes using Undo (Ctrl-Z). 

Using the Autoroute Option 
The Trace-Router autorouter option is available in the demonstration mode or if you have purchased it. This feature 
is used to convert your nets into electrical tracks as with manual routing discussed previously. However, on dense 
designs it can save you many hours or days of work. The autorouter can take an unrouted design and route it within 
minutes quite often.  

You can use the autorouter in many modes; on All Nets in the design, on Browsed Nets, Browsed Net Classes, on 
selected nets and on components. 

u To use the autorouter 
From the Tools menu under Auto Route Nets>, select All Nets. 

We will leave the default settings as they 
are: 

 

Simply click the Route button at the bottom of the 
dialog to start the router. This small design will easily 
route 100%.  

 
The results are displayed in a report, click OK to close 
the dialog and view the completed routes. 
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The routed design might look something like this below. This will vary depending on how you placed the design. 

u Save the design 
The PCB design has already been named when you translated from Schematic to PCB, we named it Tutorial.pcb. We 
named it this so it matches the name of the Schematic. This will become more important later on when you run the 
integrity checks before plotting. 

For now, click the Save icon on the toolbar or Save from the File menu. 

Pouring Copper into areas 
Copper Pour is used to flood areas of a PCB layout with copper, usually connected to a nominated signal through 
‘thermal’ connections, typically Ground (GND) or VCC. This facility will then create voids around tracks, component 
pads, vias and other electrical obstacles.  

For this we have the Add Copper Pour Area and Pour Copper options. 

If a copper area is to be inserted without the need for voids around unconnected tracks, components or pads, the 
Add Copper option can be used. 

The principle of this facility is to insert a Copper Pour Area and ‘pour’ the copper into this area. 

u To create a Copper Pour Area 
From the Add menu, select Add Copper Pour Area> Rectangle Other Pour Area options are available for adding 
different shapes. We will add the pour area to the Top Copper layer, pour areas and poured copper can be added to 
any electrical layer. To change layers, select the pour area and click L followed by <Enter> as we did when editing 
tracks. 

The shape can be created on the design and the Pour Area can be drawn protruding outside the board outline. 
DesignSpark PRO will pour the copper using the Spacing rules and rules defined for the Pour area. 

Following the picture below of our example, drawn in a basic rectangle pour area shape, this is shown in black in the 
top left hand side of the design: 
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For this example, you will see how easy it is to add a poured copper area. 

Right click on the pour area. 

From the shortcut menu select Pour Copper. 

 
A dialog is displayed from where you can select parameters for the poured area, such as the net name association 
and thermal connections etc. 

 
For this exercise, leave the Net Name blank and simply click OK. 

A warning dialog is displayed. Normally, you won’t see this as you would associate the copper with a net, such as 
GND. 

 
Notice that the poured copper has obeyed the Spacing rules of all defined items to copper including Board to Shape 
rules. 
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u To remove poured copper from a copper pour area
To remove a poured copper area (including any thermal spokes), simply select the area outline and select Clear 
Copper from the shortcut menu. This removes the copper but not the Copper Pour area. 

When using poured copper remember you shouldn’t use Delete but should always use Clear Copper. Copper Pour 
Areas can be modified at any time and the area re-poured using the option from the shortcut menu. If you wish to 
completely remove the copper and area, you must use Clear Copper first and then delete the area afterwards using 
the Delete key.  

u To make the copper Pour Area intelligent
There are more facets to the poured copper than we have discussed above.

The poured copper can also have a net 
name associated with it so that when 
poured, pads are connected via thermal 
spokes to the copper itself. To do this, 
select the pour area and from the shortcut 
menu select Add To Net. Select the net 
name required from the list and then re-
pour the copper. Try it again using 0V as 
the net name and click OK. 

From the Settings menu, choose Design 
Technology and Rules tab. This allows you 
set up your copper pouring rules.  

Use the Isolation Gap, Spoke Width and 
Number Of Spokes settings, this defines 
how the Thermal spokes will be presented 
in your design. 
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Copper Pour Area outlines are not plotted 
and will not appear on your plots, they 
provide the system with an intelligent area 
into which the copper can be poured. 

 

 

Adding Dimensions 
Dimensions used for documenting the physical measurements of the PCB and can be added using the Add 
Dimension option from the Add menu. This is used to display (in the form of a dimension) lengths of items, radii of 
arcs and angles between lines. 

 

u To insert dimensions 
Select Add Vertical Dimension (Ctrl-J) from the Add menu and Dimension >.  You can also select Horizontal and 
other dimension types. 

Select the first point to start the leader line (the board outline for example), then the second snap point which will 
be the outer dimension limit. 
Move your cursor away from the design so that the dimension measurement text and leader lines can be placed. 
Click the mouse to place the text. You can move the lines afterwards to make adjustments. Aspects of the 
dimensions (text, values, lines, arrows etc.) can be customised to your own requirements using Defaults and 
Properties of the dimension. 

Checking the Design Integrity 
The Integrity Check option is available in both the Schematic and PCB editors on the Tools menu. This is used to 
compare and verify designs and make changes in the PCB so that they are both in-sync with each other at all times. 

u To check the designs  
You can use the Schematic/PCB Check option from the Tools menu at any time. By default, the file used for the 
comparison will be the same name as that used for the Schematic (or PCB design if running from the Schematic 
editor). 

When run, if there are no differences, the following dialog is displayed: 
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If differences are found, Notepad will be run to view a detailed report. The report will give you a list of changes that 
would have to be made to the PCB in order to make it match the schematic (the schematic always being the 
‘master’). You can then perform these changes automatically by selecting the Yes button on the dialog. 

 
Run this option on our tutorial design, there should be no differences. If there are, click the Yes button and make 
the changes. 

u To back annotate name changes to the Schematic  
Back annotation changes can be made in the PCB, these can also be passed back to the schematic using the Back 
Annotation option from the Tools menu. When run, it will report and allow you to perform any back annotation 
changes to the Schematic that are ‘pending’. 

u To validate the electrical connectivity of the design  

Another essential aspect to the overall design integrity check is the validation of full electrical connectivity in the 
PCB design. You need to be sure that all connections have full electrical paths between each point. This would 
include electrical paths through copper planes, vias, plated and non-plated through-holes and through tracking. 

Run the Connectivity Check from the Tools menu. This will display a dialog from which to select what to check. 

 
A report of all the connectivity is displayed. Any warnings or errors are reported and should always be investigated. 
The full report above the summary explicitly lists these warnings and errors so you can locate them. 

Design Rules Checking 
Before outputting your design for manufacture, you must run the Design Rules Check option. This dialog contains 
check boxes that enable various checks to be made. The checks are made against the Spacing rules defined. This is 
also used to check various manufacturing rules have been obeyed.  

When errors are found, Error Marker letters are added to the design on the appropriate layer to help you find and 
correct the actual error. 

u To run a Design Rules Check 
Select the Design Rule Check option from the Tools menu. 
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A dialog is displayed that allows you to control which items are included in the check.  

A minimum check would be for Spacings but other checks can be made as required. 

Click Check to run the DRC. 

u To locate DRC error markers 
After running a design rules check, you can find the error markers in the design using the Goto browser. 

This is available by right-clicking the mouse 
with the cursor positioned over the 
DesignSpark PRO framework (the area 
around the design or over one of the 
menu items or toolbar icons). 

 

Select the Goto option from the menu list. 

When the Goto browser is displayed, from the list of 
available Goto options, drop the list down and select 
Errors. 

 
This list is used to view all the design error markers as a 
sorted list. It is displayed in an 'active' browser. You can 
use a double click of the mouse to select an error by 
name in the browser and then the error marker in the 
design. The error marker will be brought into the centre 
of the display so it can be seen, checked and cleared.  
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Reports, Part Lists and Net Lists 
DesignSpark PRO can generate reports where all vital aspects of the design can be reported in detail. The reports 
also include a set of ‘standard’ reports like Parts lists and bill of materials (BOMs).  

User defined Parts lists and Netlists can also be generated using the Custom Reports option. 

These reports are all available on the Output menu. 

During your testing of the options, run the reports to see what they can produce for you. Each report will be 
displayed using Notepad, close the report once viewed. 

 
You’ll see on the list plenty of ‘general’ reports plus User Reports that can be created and customized by you to 
your own requirements. 

Plotting the Design 
DesignSpark PRO provides you with an output mechanism for generating professional PCB layout plots for 
manufacturing. All the plot and drilling outputs are located in one easy-to-use dialog. 

From the Manufacturing Plots option on the Output menu, you can output all types of plots. You can select the 
layer or combinations of layers to plot. You can also set the scale, rotation, the position on the plot and the plotter 
type. All plots and outputs can be delivered in one button press once set up. 

Plotter types available are: 

· Gerber 274-D, 274-X (extended Gerber format) and Gerber X2 format photo-plots 

· Numerically controlled drilling (NC Drill) information 

· Windows printer plots using any installed Windows driver 

· Active PDF files 

· HPGL Pen Plots 

· Standard and customised reports 

· ODB++ format files 
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Plot types 

Plots are available for all aspects of the design but because DesignSpark PRO uses a configurable output 
mechanism, it means that almost any plot required can be generated:  

· Top, bottom and inner electrical signal layers 

· Silk screen layers 

· Solder resist plots 

· Solder paste masks 

· Copper and power plane (full or split) layers 

· Assembly and manufacturing drawings 

· Drill ident/symbol drawings 

· NC Drilling files 
 

DesignSpark PRO can also output to DXF and IDF formats but these are not generated as part of the Printing & 
Plotting mechanism. 

u To output plots 
Click on the Manufacturing Plots option on the Output menu.  

When you first enter this dialog, DesignSpark PRO automatically creates you a set of plots based on the layers in the 
design. These can be edited and amended at any time. Plots defined and customised can be saved for reuse using 
the Save Job button. 

 

 

The dialog itself is split into four main sections for saving the plot settings, defining the rules of the plot, setting up 
the plotter type and device options. 

The top part of the dialog is used to save plot jobs if you customise your plots (like plotting Top Silk and Assembly 
together for example). You can use this to recall existing plot jobs to other designs: 

 
The left side of the dialog is the plot to be output. This is automatically named the same as the layer but can be 
user-defined and edited by you. The check box indicates whether that plot/layer will be plotted when Run is 
pressed. 
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The tabbed portion of this dialog defines the plotter type used for the selected plot/layer. Each tab defines different 
properties of the plot, like the type, the layers included in that plot, the settings (powerplane settings, thermal sizes, 
pad under/oversize for solder masks etc.) and the position of the plot on the paper/film. 

The Options button and Device Setup button allow you to change the settings of the selected plotter type. For 
example, changing from RS-274-D to 274-X format for Gerber. 

The Options button also allows you to define which folder the plots will be plotted to. 

Click the Run button to output all the selected plots. 

Concluding The Tutorial 
This concludes the tutorial. As we said above, it’s a quick run through to give you an idea of the flow of the 
DesignSpark PRO product and how easy it is to use. 

If you would like more information about DesignSpark PRO, please contact our sales office or visit our web site 
https://www.rs-online.com/designspark/pcb-software 

https://www.rs-online.com/designspark/pcb-software 



