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Thank you for your interest in the CY3280-BK1 Universal CapSense® Controller (UCC) Basic Kit 1.
The kit contains CY3280-20x34 and CY3280-21x34 Universal CapSense Controller boards. These
boards are designed for easy prototyping of CY8C20x34 and CY8C21x34 CapSense family designs
with predefined control circuitry and plug-in hardware. The kit also includes programming hardware

and 12C-to-USB bridge for tuning and data acquisition.

This guide provides details on the kit contents, installation procedures, hardware descriptions,
schematics, and the bill of materials. The document also demonstrates how to use the code
examples that accompany the kit. Visit www.cypress.com/go/CY3280-BK1 for the latest information

about this kit.

1.1 Kit Contents

m Universal CapSense Controller boards
o CY3280-20x34 UCC board
o CY3280-21x34 UCC board
m Universal CapSense Controller board accessories
a Universal CapSense modules
- CY3280-SLM Universal CapSense Linear Slider Module
- CY3280-BBM Universal CapSense Prototyping Module
- 1.5 mm and 3 mm thick polycarbonate overlays with adhesive
a CY3217-MiniProgl programmer
- Mini USB 2.0 retractable cable
o CY3240-12USB Bridge
m Chip Samples
o CY8C20434-12LQXI
0 CY8C21434-24LQXI
m Software and documentation
o CY3280-BK1 kit CD
- PSoC Designer installation file
- CY3280-BK1 specific code examples
- CY3280-BK1 kit guide
- CY3280-BK1 hardware design files
- CY3280-BK1 quick start guide
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1.2 Factory Default Configuration

When shipped, the CY3280-20x34 and CY3280-21x34 boards are preprogrammed to run the
CapSense projects described in 5.1 My First CapSense (CY8C20x34) Project and 5.2 My First
CapSense (CY8C21x34) Project, respectively.

1.3 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device
for your design, and to help you to quickly and effectively integrate the device into your design. For a
comprehensive list of resources, see the knowledge base article “How to Design with PSoC® 1,
PowerPSoC®, and PLC — KBA88292". Following is an abbreviated list for PSoC 1:

m Overview: PSoC Portfolio, PSoC Roadmap

m Product Selectors: PSoC 1, PSoC 3, PSoC 4, PSoC 5LP

m In addition, PSoC Designer includes a device selection tool.
]

Application notes: Cypress offers a large number of PSoC application notes covering a broad
range of topics, from basic to advanced level. Recommended application notes for getting started
with PSoC 1 are:

o Getting Started with PSoC® 1 — AN75320

7 PSoc®1- Getting Started with GPIO — AN2094

7 PSoC® 1 Analog Structure and Configuration — AN74170
a PSoC® 1 Switched Capacitor Analog Blocks — AN2041

o Selecting Analog Ground and Reference — AN2219

Note: For application notes related to CY8C29X66 devices, click here.
m Development Kits:

o CY3210-PSoCEvall supports all PSoC 1 Mixed-Signal Array families, including automotive,
except CY8C25/26xxx devices. The kit includes an LCD module, potentiometer, LEDs, and
breadboarding space.

o CY3214-PSoCEvalUSB features a development board for the CY8C24x94 PSoC device.
Special features of the board include USB and CapSense development and debugging
support.

Note: For development kits related to CY8C29X66 devices, click here.

The MiniProgl and MiniProg3 devices provide interfaces for flash programming and debug.
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1.3.1 PSoC Designer

PSoC Designer is a free Windows-based Integrated Design Environment (IDE). Develop your
applications using a library of pre-characterized analog and digital peripherals in a drag-and-drop
design environment. Then, customize your design leveraging the dynamically generated API
libraries of code. Figure 1-1 shows PSoC Designer windows. Note: This is not the default view.

1. Global Resources — all device hardware settings.

Parameters — the parameters of the currently selected User Modules.

Pinout — information related to device pins.

Chip-Level Editor — a diagram of the resources available on the selected chip.
Datasheet — the datasheet for the currently selected UM

User Modules — all available User Modules for the selected device.

Device Resource Meter — device resource usage for the current project configuration.
Workspace — a tree level diagram of files associated with the project.

Output — output from project build and debug operations.

© o NG A WD

Note: For detailed information on PSoC Designer, go to PSoC® Designer > Help > Documentation >
Designer Specific Documents > IDE User Guide.

Figure 1-1. PSoC Designer Layout
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1.3.2 Code Examples

Introduction

The following webpage lists the PSoC Designer based Code Examples. These Code Examples can
speed up your design process by starting you off with a complete design, instead of a blank page

and also show how PSoC Designer User modules can be used for various applications.

http://www.cypress.com/go/CapSenseCodeExamples

To access the Code Examples integrated with PSoC Designer, follow the path Start Page > Design

Catalog > Launch Example Browser as shown in Figure 1-2.

Figure 1-2. Code Examples in PSoC Designer

Start Page %0
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In the Example Projects Browser shown in Figure 1-3, you have the following options.
m Keyword search to filter the projects.

m Listing the projects based on Category.

m Review the datasheet for the selection (on the Description tab).

|

Review the code example for the selection. You can copy and paste code from this window to
your project, which can help speed up code development, or

m Create a new project (and a new workspace if needed) based on the selection. This can speed
up your design process by starting you off with a complete, basic design. You can then adapt that
design to your application.

Figure 1-3. Code Example Projects, with Sample Codes

Example Project Browser
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PSoC Designer Help

Visit the PSoC Designer home page to download the latest version of PSoC Designer. Then, launch
PSoC Designer and navigate to the following items:

IDE User Guide: Choose Help > Documentation > Designer Specific Documents >

IDE User Guide.pdf. This guide gives you the basics for developing PSoC Creator projects.
Simple User module Code Examples: Choose Start Page > Design Catalog >

Launch Example Browser. These code examples demonstrate how to configure and use PSoC
Designer User modules.

Technical Reference Manual: Choose Help > Documentation >

Technical Reference Manuals. This guide lists and describes the system functions of PSoC
devices.

User module datasheets: Right-click a User module and select “Datasheet.” This datasheet
explains the parameters and APlIs of the selected user module.

Device Datasheet: Choose Help > Documentation > Device Datasheets to pick the datasheet
of a particular PSoC device.

Imagecraft Compiler Guide: Choose Help > Documentation >

Compiler and Programming Documents > C Language Compiler User Guide.pdf. This guide
provides the details about the Imagecraft compiler specific directives and Functions.

Technical Support

If you have any questions, our technical support team is happy to assist you. You can create a
support request on the Cypress Technical Support page.

If you are in the United States, you can talk to our technical support team by calling our toll-free
number: +1-800-541-4736. Select option 8 at the prompt.

You can also use the following support resources if you need quick assistance.

m Self-help
m Local Sales Office Locations
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14 Acronyms
Table 1-1. Acronyms Used in this Document
Acronym Definition Acronym Definition

ADC analog-to-digital converter LSB least significant bit

AEC Automotive Electronic Council MSB most significant bit

BBM bread board module PCB printed circuit board

BK1 basic kit 1 PRS pseudo-random sequence
CSA_EMC CapSense successive a_pprommatlon PSoC Programmable System-on-Chip

electromagnetic compatible

CSD CapSense Sigma Delta PWD pulse width discriminator

DC direct current PWM pulse width modulator
EEPROM electronically erasable programmable QFN quad flat no leads

read-only memory

GPIO general purpose input/output SLM slider module

12C inter-integrated circuit SoIC small-outline integrated circuit
ICE in-circuit emulator SPI serial peripheral interface

IDE integrated design environment SSOP shrunk small outline package
IRDA Infrared Data Association UART unlvers_al asynchronous receiver /

transmitter
ISSP In-system serial programmer UsSB universal serial bus
LED light emitting diode
15 Documentation Conventions
Table 1-2. Document Conventions for Guides
Convention Usage

Displays file locations, user entered text, and source code:

Courier New c-\ .. cd\ice\

Displays file names and reference documentation:

Italics Read about the sourcefile.hex file in the PSoC Designer User Guide.

Displays keyboard commands in procedures:

[Bracketed, Bold] [Enter] or [Ctrl] [C]

Represents menu paths:

File > Open File > Open > New Project

Displays commands, menu paths, and icon hames in procedures:

Bold Click the File icon and then click Open.

Displays an equation:

Times New Roman 24+2-4

Text in gray boxes Describes cautions or unigue functionality of the product.
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This chapter describes how to install and configure the CY3280-BK1 Universal CapSense Controller
kit.

2.1 Kit Installation

To install the kit software, follow these steps:

1. Insert the kit DVD into the DVD drive of your PC. The DVD is designed to auto-run and the kit
installer startup screen appears.

Note You can also download the latest installer from www.cypress.com/go/CY3280-BK1. Three
types of installers are available for download:

a. CY3280-BK1 ISO (Create DVD): This file (ISO image) is an archive of the optical disc
provided with the kit. You can use it to create an installer DVD or extract information using
WinRar or similar tools.

b. CY3280-BK1 Kit Setup: This executable file installs the DVD contents, which includes PSoC
Programmer, PSoC Designer, code examples, kit hardware files, and user documents.

c. CY3280-BK1 Kit Only (without prerequisites): This executable file installs only the kit contents,
which includes kit code examples, hardware files, and user documents.

2. Click Install CY3280-BK1 to start the installation, as shown in Figure 2-1.
Figure 2-1. Kit Installer Startup Screen
5l c¥3280-BK1 UUCC Board 9=

=7 CypRESS'

PERFORM

CY3280-BK1 UCC Board

Install the CY3280-BK1...

& 2014 Cypress Semiconductor Corporation. All rights reserved
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Note If auto-run does not execute, double-click the cyautorun.exe file on the root directory of the
DVD, as shown in Figure 2-2.

Figure 2-2. Root Directory of DVD

File Edit Wiew Favorites Tools  Help '#
@ Back ~ [ Iﬁ: /':" Search lL Fuolders '
Address |$J Fi, v| Go

IJ CY3280-BK1 /’ Documnentation IJJ Firmnware —/I Hardware

| | | |

== . == f T4 aukorun

L,J Prerequisite /’ PSoiC Designer d‘J PSoiC Programmer = Setup Information
1 1 LEB

_ cyaukarun setup
5} Cypress Aukorun Applet 45 % 48
Cypress Semiconductor

120 File

3. The InstallShield Wizard screen appears. On this screen, choose the folder location to install the
setup files. You can change the location for the setup files using Change.

4. On the Product Installation Overview screen, select the installation type that best suits your
requirement. The drop-down menu has three options - Typical, Custom, and Complete, as
shown in Figure 2-3.

5. Click Next to start the installation.
Figure 2-3. Installation Type Options

r
© Cylnstaller for CY3280-BK1 1.0 [ [

Product Installation Overview
Choose the install type that best suits your needs

Choose the type of installation

Product:
CY3280-BK1

Installation Type:

Ingtalls the most common features of
CY3280-BK1.

o> [ Coed
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6. When the installation begins, a list of packages appears on the Installation Page. A green check
mark appears adjacent to every package that is downloaded and installed.

7. Wait until all the packages are downloaded and installed successfully.
8. Click Finish to complete the installation, as shown in Figure 2-4.

Figure 2-4. Installation Complete

L Y
& Cylnstaller for C¥3280-BK1 1.0 |2 ||

==# CYPRESS

PERFORM

Contact Information

=

ame: * saga
Company:
Email: *

* Indicates a required field
Privacy Policy

Launch PScC Designer 5.4 SP1
View Release Notes

View User Guide

Launch Update Manager

Continue Without Contact Information

Note Advanced users can go to Code Examples chapter on page 41.
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2.2 PSoC Designer

PSoC Designer 5.4 SP1 is the revolutionary integrated design environment (IDE) that you can use to
customize PSoC to meet your specific application requirements. You can develop applications using
a library of pre-characterized analog and digital peripherals in a drag-and-drop design environment.
Then customize your design, leveraging the dynamically generated API libraries of code. Finally,
debug and test your designs with the integrated debug environment including in-circuit emulation
and standard software debug features.

1. To open the application, click Start > All Programs > Cypress > PSoC Designer <version> >
PSoC Designer <version>,

2. Click File > New Project, to create a new project; click File > Open Project to work with an
existing project.

Figure 2-5. PSoC Designer Interconnect View

& ANTS5320  PSeC Designer 5.4 | I
Ble Edt Yew Project Interconnect Buld Debup Program  [ooks  Window Help
DEHS, EES EE SRR, (v 0, marr dEEET, FEIZ2 0P8, AMex -QQ @6 i
Global Resources - ANTS320 = 1 X ANT5320 [Chip] = 4 b x  |Datashest- E2ADC > B X User Modules ~ B X | Workspace Explorer -3 x
Howes Setlr 5.0V / 24MHz AT 6o 5, OF A | | Home | Featwes | Desciphon | Maq b 1gh h B s T EX e )
S poret 3 I g, A1 [ User Modhics ~|[5T Werkapace BN7ER0 (1 peorect]
PLL Mode Disbe = [ ADCs = T ANTEI0 [CYRC29465-24P]
Sleep_Times 512 Hz /2™ Easy ADC Datasheet ‘a E";\tm =& A'I\l?mlt‘m;] x_
VOl-Spcl 16 [ \ 3 e AR 2 Detsig i L:;;M?sszﬂ-lm:h:uddes
VC2=VCIA 16\ 2 l i DUALADC W E:20C 0
Vi3 Suucei V2 b a rau PSoC® Blocks g o Lot
¢ DUALADCE 5
Power Setting [ Vee / SpaClk 4 fa EzADC I{ 6 ‘-I W LEDT_PwM
Selects the nominal operation voltag = Digital iog #a SARG '\ ! W LEDZ PwM
Parameters - EZADC._1 ~ax i el “a TRIADC o B a20rees)
Mame  E=aDC1 a2 s st 5 1w TRIAOCH samm ey
{1stor 2nd & [ Ampltiers )
i Order) L H [ Analog Comm 3
I [ Counters e
DataFumst Ursioner” g \ R Supported Devices: CYEC2x234 CVaC2 | o = oot
Resokaion 1482 2 T m_m CYBCIEEY CYECIEY, CYBC2AX4Y, LB f___iwu
,S a, 000? ‘ Configuration 2 1 1 2 & [ Fiters
sﬁq‘d G mm : i [ Generic
I ” /| (3 LED Dawany
- Faatiirac and ]
= p g (23 ’
Pinout - AN75320 -ax = @ % Device Resource Meter -0 x
B PO0]  Post_0_0, S1GCPL, High & grwamrm Build v Digital Blocks Totat 16 Used 4
B PO{1]  AndlogColumn_lnputhl | | =
B POZ  Pol 02 SICRU, Hig &Jﬂ;fu%mmg et N (T |
B PO Peit_0_3 SW9CPU. High | [ibvpeacconiiohl sim Anslog Diocks Total 12 Used 2
PO[]  Pest_0_4, SIACPU. Higl ’m‘::;*"' _ [T |
B PO AnslogOuBul 1. Anada | |\WRNSE L AN wses 13 bytes in SRAM bark 0 "% RAM Totst 2048 Used 11
B POE]  Post 0.6, SIOCPLI High | |L44M info: avea "datd e of 25 ket losated in SAM page 0 ( |
Bl PO Post_07. S1CPLL High | [LMM indo: atea ‘irtual_registers' uses 11 bytes in SRAM page 0 K / [ ]
Fl PIN]  Prat_}="%PI1 High | [LMM info: atea "dats’ e of 2 byles alocated n SRAM page 0 N L
P ol WU, High | [LMM info: atea ‘datal tem of 2 bytes ducalednSRMdpauel] = FOM Totat 32768 Used
= Y It ||l sea i teml 2 s inSRAM i 7 T
O Mg Cot, 08 | e e e e of 2 s oot SHAM b9 4& -
B P13]  Pot_x_oCPU, Stio ﬁggmguwg;mmgzaga Decimator Totat 1 Used T
B PI[4]  Pot_|_4, SaCPL, Hi M 267 full ouk of bytes used {does not inclade abroute areas].
= P1E5]| pa::-‘_s‘ StacPL. H: RAM 4% lull 57 bytes used (doss notinchude stack usage) (LTI
Bl PIEl  Pol 16, SIdCPLL High | |0 wih ICCMOC STDV7.05.00 12C Controber Totat 1 Used: 0
Bl P17l Pet 1 7.519CPU High | |AN75320 - O errorls) O weamingls) 14:28:20 |
P2(0]  LCD_104. StdCPLU. Stn s e
Ready,

3. To experiment with the code examples, go to Code Examples chapter on page 41.

Note For more details on PSoC Designer, see the PSoC Designer IDE Guide located at:
<Install_Directory>\PSoC Designer\<version>\Documentation

The default <Install directory> on Windows 32-bit platforms is C:\Program
Files\Cypress and on Windows 64-bit platforms is C:\Program Files(x86)\Cypress.

See Additional Learning Resources on page 6 for links to PSoC Designer training. The PSoC
Designer quick start guide is available at: www.cypress.com/?rID=47954.
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2.3 PSoC Programmer

PSoC Programmer is a stand-alone utility for programming PSoC devices.

1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer
<version>.

2. Select the MiniProg from Port Selection, as shown in Figure 2-6.

Figure 2-6. PSoC Programmer Window

=J=ed

|§ PSoC Programmer File Load
File  vigw Ol?t\nn Help Program B
(=]
| Port Selectian Alp | Programmer | Uilities | JTAG
Frogramming Parameters
File Path: E:\Brisa_Cypress11DatalCy 321 0-PSOCEVALTFirmware A5 _Example_LED_LogicShi_Example_LED_Logichex
Proarammer:. MINIProg1/08215B0C3314
Frograrmming Mode: (O Reset & Power Cycle Fower Dietect
Verification: @ on O off Connector Sp ¢ 10
Devis Fanily AutoDetection: @ on O of Clock Speed:
2966 [ Programmer Characteristics Status
z Protocol  TaG  gwD ® 185F g || Execution Time: 80 seconds
s = Vohsae: @ 5oy 33y 25y (0 1gy || Dowerdias o ON
CYEC2MEE24PH  [v Yoltage: hA
Actions Resultz |
Power On at 1:14:10 PM MINIProgl/05215B0C3314
Program Finished at
1:11:05 PH
Programming Succeeded
Doing Checkswumn
Doing Protect
Verify Succeeded
Verify 3tarting
Programming Succesded
Prograwting Starting
Erase Succeeded
Levice set to
CYECZ9466-24PXI at 32768 FLASH bytes
1:10:00 PH
Device Family set to
Z9x66 at 1:10:00 PH
Automatically Detected Device: CYBCZ9466-Z4FPXI pove

Far Help, press F1

Click File Load to load the hex file.

Use the Program button to program the hex file onto the chip.

When programming is successful, “Programming Succeeded” appears in the Actions pane.
Close PSoC Programmer.

Note For more details on PSoC Programmer, see the user guide at the following location:
<Install_Directory>:\Program Files\Programmer\<version>\Documents.

o0k w

The default <Install directory> on Windows 32-bit platforms is C:\Program
Files\Cypress and on Windows 64-bit platforms is C:\Program Files(x86)\Cypress.
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Bridge Control Panel Overview

The Bridge Control Panel is used with CY3240-12USB Bridge to enable communication with 12C
slave devices. This program is used to configure I2C devices as well as acquire and process data
received from I2C slave devices. The Bridge Control Panel helps to optimize, debug, and calibrate
the target applications.

The main features of the application are as follows:

Controls power supply of connected devices

Supports 12C protocol

Searches and displays a list of devices connected to the bridge

Supports high-speed data reading from slave device (ToFile mode of bridge)
Configures the bridge to work at 50 k, 100 k, and 400 k CLK speed on 12C bus

For SPI protocol support: selects shift direction type (MSB first, LSB first), selects mode (00 and
01) frequency

Provides a simple format to input and output data for communication. The input data can be inter-
preted as variables of varying length

Includes different variables settings such as type, scaling, and offset

Supports a variety of data presentation and storage through charts, tables, and other formats
Saves and loads variable configurations for use with different I2C slaves

Saves and loads commands line files

Supports 12C boot loader file format
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To open the application, click Start > All Programs > Cypress > Bridge Control Panel 1.2 >
Bridge Control Panel 1.2.

Figure 2-7. Bridge Control Panel

i Bridge Control Panel

Fle Edtor Chart Execute Tools  Help

AR Tools Buttons
Tabs dior | Chatt | Tadle | Fie
wids 0 1p Command
r 05 0SensorID @lRawCount (0RawCount @1Baseline @0Baseline @lDifference @0Difference | T —_—— String
Commands
[This s & commards window - Lser must enter cominand here] Window
Opening Port
Successfully Conmected to Bridge/0000011
USB2IIC Bridge version 1.22
Results
Window
Pratocal
C T Send allsings: [ Connected 12C/5PIUSE converters: Uml%rw
wﬂml &:LIS‘ Fepeat count: |_D?‘ Biidge/O000011 | g DRtk giz Povg:er StuFI’ply
ontro
E @ Scan penod, mx:| D:‘ @ el
| iSyntax:OK | ﬁ— i Vni\tagm-i G —
Transfer Control List of Connected Status Bar

Buttons

Bridges

For more details on the Bridge Control Panel, see application note AN2352 - Communication - 12C
USB Bridge Usage or access the help topics in the Bridge Control Panel menu bar.
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The CY3280-BK1 Universal CapSense Controller kit is designed for easy prototyping of CapSense
designs with predefined control circuitry and plug-in hardware. The kit comes with controller boards
for the CY8C20x34 and CY8C21x34 PSoC devices as well as a breadboard module and a button/
slider module.

3.1 Evaluating the CY3280-20x34 CapSense Controller

To evaluate the default project programmed on CY3280-20x34 UCC, follow these steps.

1.

Ll N

© N o »

Connect the CY3280-SLM board to the CY3280-20x34 UCC board's P2 connector.
In the CY3280-20x34 boards, place the jumper on header J1 to short pins 2 and 3.
In the CY3280-SLM board, place the jumper on header J2 to short pins 2 and 3.

Connect MiniProgl to the CY3280-20x34 UCC board's ISSP connector (J3); connect it to your
PC using a USB cable.

Open PSoC Programmer.
Click Connect; connect MiniProgl to the PC.
Click the Toggle button to power the board.

Touch and move the linear slider on the CY3280-SLM module board. The corresponding LEDs
on the CY3280-SLM board light up.

Touch a button. The corresponding LED on the CY3280-SLM module board lights up.

You can touch multiple buttons simultaneously; the linear slider and buttons can also be used at
the same time.

Figure 3-1. LED Glows on Slider Touch

[TOLIE!

(IO
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1.
2.
3.

4,
Figure 3-2. Program the Device

If the default project programmed on CY3280-20x34 UCC is erased, follow these steps.
Open PSoC Programmer.
Click Connect; connect MiniProgl to the PC.

Browse and load the CY3280_20x34_SLM.hex file.

Kit Operation

Note The hex file is located at: <Install_Directory>:\Cypress\CY3280-BK1
\<version>\Firmware\CY3280_20x34_SLM

PSoC Programmer

File  Wiew  Options Help

@EleceBnBa 0D

Click the Program button to program the device.

| Part Selection

Ap | Prograrmmer | Utilities | JTAG

@ MINIFrog1 /882156 DB TR0A

Frogramming Parameters

File Path:

C\Documents and Seftingsibvibdy Documentsi\Downloads\CY3280-BMMM_Example_Projectsi20x34_CSAPSaCD
1

4 >
Frogrammer. hIMNIProg1/88215B0B1604
Frogramming Mode: ) Reset (&) Power Cyele Power Detect
Merification: O on @ of Connector, Sp 10p
AutoDetection:
Devics Faniy AutoDetection; @ on O of Clock Speed:
:2-6;3-4 =) Frogrammer Characteristics Statuz
Protosol: e GwD @ 1ssP |z ExecutionTime: 11.6seconds
Devi 2 Power Status
L A ||| Vahate: @ siny @A O 25k O el (|G Ol
| CYBC20434-12LFAC  » | Yoltage: [y

Actions
Power On at 1:54:46
Program Finished at

PN
1:54:43 PN

Results

MINIFrogl/GB21560B1604

Programming Succeeded

Doing Checksum
Doing Protect

Progremming Succeeded
Progremming Starcing

Erase Succeeded

For Help, press F1

Similar steps can be followed to evaluate the CY3280-21x34 CapSense controller.
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4.1 CY3280-20x34 Universal CapSense Controller Board

The CY3280-20x34 Universal CapSense Controller Kit is designed to prototype rapidly and develop
CapSense-based solutions around the CY8C20x34 family of CapSense controllers. The following

figure highlights important board components and connectors.

Figure 4-1. CY3280-20x34 Universal CapSense Controller Kit - Top View
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System Block Diagram
Figure 4-2 shows the block diagram of the CY3280-20x34 Universal CapSense Controller Kit.

The kit can be powered from five different sources; to select a source, place the jumper on power
select header J1. Power supply from the battery connector and the DC socket is short-circuit pro-
tected to avoid mishap due to accidental short between these sources. The 5-V regulator output,
supply from expansion header, and supply from ISSP connector are shorted. Supply from the ICE-
Cube connector is fed directly to the CapSense controller. An I2C controlled variable power supply is
also part of this Kkit.

Any Universal CapSense Module board can be connected to the kit via the Universal CapSense
Module connector P2. SPI and auxiliary 12C pins from the CapSense controller are routed to the
expansion header, J2. Connector P1 is used to interface ICE-Cube, the emulator needed for in-cir-
cuit debugging of CapSense projects. The CapSense controller is programmed through the ISSP
connector J3 using MiniProg1l.

Figure 4-2. System Block Diagram of CY3280-20x34 Universal CapSense Controller Board

Power LED Power LED
(D1) (D2)
'} A
ISSP Connector, J3
Battery Supply via
Connectors BH1 &
BH2 v ¢ ICE-Cube Connector, P1
Short Circuit [ Adjustable Supply Selection | | CapSense Controller
Protection | | OV Regulator [ o ulator [ *] Jumper, J1 x| (CY8C20000)
Supply via DC Expansion Header, J2
Supply Jack R— QA i '
Connector J5 ! ‘C
Universal CapSense
ISSP Module Connector, P2
. Connector, J3
Supply via
Expansion Header
J2
Supply via ISSP

connector J3

Supply via ICE-
Cube Connector P1
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4.1.2 Power Sources

4.1.2.1 Power Supply Nets

The board has several power nets. Following are the definitions of the different power nets.

m VIN (9 Vor 12 V): This is the input power before it is fed into any of the regulators. A 9-V to 12-V
power supply adapter or a 9-V battery is used as the source.

5 V: This is fed by the 5-V regulator output, pin#1 of J2 or pin#1 of J3.

VADJ/Vad;j: This is fed by 5 V and is the output of the onboard adjustable regulator.

VCC: This is the power from either 5 V or VADJ. The source of VCC can be chosen using the J1
header. It is used to power the CapSense controller.

Figure 4-3. Power Supply System Schematic
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Power Supply Configuration Examples

Power CapSense Controller at +5 V from Onboard Regulator

1. Connecta 9-V to 12-V power supply adapter to the DC power socket J5 or connect a 9-V alkaline
battery to the battery terminals. (Battery terminals on BH1 and BH2 are not mounted in the kit.)

2. Place the jumper on header J1 to select 5V as VCC.

Power CapSense Controller from Onboard Adjustable Regulator

1. Connect a 9-V to 12-V power supply adapter to the DC power socket J5 or connect a 9-V alkaline
battery to the battery terminals. (Battery terminals should be soldered on footprints BH1 and
BH2.) You can also apply source at pin#1 of J2 or pin#1 of J3.

2. Place the jumper on header J1 to select VADJ as VCC.

Power CapSense Controller Directly from ISSP Header

1. Insert the MiniProgl or I2USB Bridge to the ISSP header J3. Power the connected device.
2. Place the jumper on header J1 to select 5 V as VCC.

Power CapSense Controller from ICE-Cube

Connect the RJ-45 socket from ICE-Cube to connector P1. There are no specific requirements for
placing jumper on header J1.

Hardware Description

CapSense Controller (CY8C20x34)

CYB8C20000 48-QFN is the onboard CapSense controller. CY8C20000 supports programming and
in-circuit debugging of PSoC Designer projects targeted for the CY8C20x34 family of devices.

Cypress's CY8C20x34 is a low-power, high-performance, programmable touch-sensing controller
family that has the following features:

m CapSense Successive Approximation Electromagnetic Compatible (CSA_EMC) capacitive sens-
ing technology

Supports up to 25 capacitive buttons and 6 sliders

Proximity sensing up to 2 cm (with onboard PCB trace)

2.4V to 5.25 V operating voltage

Up to 28 GPIOs

Communication interfaces:

a 12C slave with 50 kHz, 100 kHz, or 400 kHz selectable speed
o SPI master/slave 46.9 kHz to 3 MHz selectable speed
EEPROM emulation

8 KB flash and 512 B RAM

Variety of packages: 16-QFN, 24-QFN, 32-QFN, 48-QFN, 8-SOIC, 16-SOIC, 28-SSOP, 30-Ball
WLCSP

m Watchdog and sleep timers
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Figure 4-4. CapSense Controller CY8C20000 Schematic
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Universal CapSense Module Connector

{ CY8C20000 QFN4§

Hardware

The CY3280-20x34 has an expansion port, P2, designed to connect the UCC module boards. The
controller board can be used with any of the Universal CapSense module boards. The boards can
be interfaced to the CY3280-20x34 via the 44-pin connector, P2. The pin mapping for the port P2 is
shown in the following figure.

Figure 4-5. Universal CapSense Module Connector Schematic
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4.1.4.3 ISSP

In-system serial programmer (ISSP) is used to program the device using MiniProgl. Plug in the Mini-
Prog device to the ISSP header J3. The ISSP connector is also used to connect the 12USB bridge to
communicate between the PC and controller board. The pin mapping for the ISSP connector is
shown in the following figure.

Figure 4-6. ISSP Header J3 Schematic
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2 XRES 1 I
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HOR 1x5
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XRES/INT (pin# 3 of ISSP header J3) is routed to either XRES or P1_5 pin of the CapSense control-
ler. The selection is made using the J4 header.

Figure 4-7. XRES Pin Selection Header J4 Schematic
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4.1.4.5 Expansion Header

SPI and auxiliary 12C pins (P1_5, P1_7) of the CapSense controller are routed to the expansion
header J2.

Figure 4-8. Expansion Header J2 Schematic
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ICE-Cube Debug Connector

The ICE-Cube debugger allows to debug and view the content of specific memory locations. The
ICE-Cube debugger can be connected to the board through port P1. The following figure shows the
schematic view of the ICE-Cube debug connector.

Figure 4-9. ICE-Cube Debug Connector P1 Schematic
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Note The current revision of the kit has known issues with debugging and the connector is not pop-
ulated; see the release notes for a workaround.
Adjustable Regulator - VADJ

The CY3280-20x34 Universal CapSense Controller board has an on-board adjustable regulator.
Regulated 5-V output from LM117 is used as the source. The factory setting is 3.3 V.

VADJ being the output of LP387ES-ADJ, follows this equation:
VADJ =1.216 x (1 + Rx/ Ry)

Where,

Rx is the resistance between VOUT and ADJ terminal of regulator LP3875. From the schematic, Rx
corresponds to 8.87 KQ.

Ry is the resistance between ADJ and GND terminal of regulator LP3875. Load Ry is adjusted by
sending 12C commands via ISSP connector J3.

I2C command format to vary Ry

W <7bit 12C Address = 0x2D> <0x00> <(Data Byte),5>
Where,

Ry = (Data Byte) x (10K/256)
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4.1.4.8 Power LEDs

Hardware

The LEDs are used to show the status of the controller board. LED D1 lights up when the board is
powered by any of the power sources. LED D2 lights up when the CapSense controller is powered.

Figure 4-10. LEDs D1 and D2 Schematic
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CMod is the test point provided on the CY3280-20x34 Universal CapSense Controller board to

probe voltage on capacitor C2.
Capacitor C2, popularly known as modulation/integration capacitor (CMod), is the only external com-
ponent required by the CapSense CSA_EMC algorithm.

For more details on CMod, see the CSA _EMC User Module datasheet.
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Embedded in Tomormow’

4.2 CY3280-21x34 Universal CapSense Controller Board

Hardware

The CY3280-21x34 Universal CapSense Controller Kit is designed to prototype rapidly and develop
CapSense-based solutions around CY8C21x34 family of CapSense controllers. The following figure

highlights important board components and connectors.

Figure 4-11. CY3280-21x34 Universal CapSense Controller Kit - Top View
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System Block Diagram
Figure 4-12 shows the block diagram of the CY3280-21x34 Universal CapSense Controller kit.

The kit can be powered from five different sources; to select a source, place the jumper on power
select header J1. Power supply from the battery connector and DC socket is short-circuit protected
to avoid mishap due to accidental short between these sources. The 5-V regulator output, supply
from expansion header, and supply from ISSP connector are shorted. Supply from the ICE-Cube
connector is fed directly to the CapSense controller. An I2C-controlled variable power supply is also
part of the kit.

Any Universal CapSense Module board can be connected to the kit via the Universal CapSense
Module connector P2. SPI and auxiliary I12C pins from the CapSense controller are routed to expan-
sion header, J2. Connector P1 is used to interface ICE-Cube, the emulator needed for in-circuit
debugging of CapSense projects. CapSense controller is programmed through the ISSP connector
J3 using MiniProg1l.

Figure 4-12. System Block Diagram of CY3280-21x34 Universal CapSense Controller Board
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Power Supply

Nets

Hardware

The board has several power nets. Following are the definitions of the different power nets.

m VIN (9 Vor 12 V): This is the input power before it is fed to any of the regulators. A 9-V to 12-V
power supply adapter or a 9-V battery is used as the source.

5 V: This is fed by the 5-V regulator output, pin#1 of J2 or pin#1 of J3.
VADJ/Vad;j: This is fed by 5 V and is the output of the onboard adjustable regulator.
VCC: This is the power from either 5V or VADJ. The source of VCC can be chosen using the J1

header.

m SMP_VCC: This is fed by VCC (filtered) or voltage pump. It is used to power the CapSense con-

troller.

Figure 4-13. Power Supply System Schematic
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42.3.2

4.2.3.3

4234

4.2.4

4241

Hardware

Power Supply Configuration Examples

Power CapSense Controller at +5 V from Onboard Regulator

1. Connecta 9-V to 12-V power supply adapter to the DC power socket J5 or connect a 9-V alkaline
battery to the battery terminals. (Battery terminals on BH1 and BH2 are not mounted in the kit.)

2. Place the jumper on header J1 to select 5V as VCC.

Power CapSense Controller from Onboard Adjustable Regulator

1. Connect a 9-V to 12-V power supply adapter to the DC power socket J5 or connect a 9-V alkaline
battery to the battery terminals. (Battery terminals should be soldered on footprints BH1 and
BH2.) You can also apply source at pin#1 of J2 or pin#1 of J3.

2. Place the jumper on header J1 to select VADJ as VCC.

Power CapSense Controller Directly from ISSP Header

1. Insert MiniProgl or 12C-USB Bridge to the ISSP header J3. Power the connected device.
2. Place the jumper on header J1 to select 5 V as VCC.

Power CapSense Controller from ICE-Cube

Connect the RJ-45 socket from ICE-Cube to connector P1. There are no specific requirements for
placing jumper on header J1.

Hardware Description

CapSense Controller (CY8C21x34)

The CY8C21001 56-SSOP is the onboard CapSense controller. CY8C21001 supports programming
and in-circuit debugging of PSoC Designer projects targeted for the CY8C21x34 family of devices.

Cypress's CY8C21x34 is a low-power, high-performance, programmable touch sensing controller
family. It has the following features:

CapSense Sigma Delta (CSD) capacitive sensing technology

Supports up to 24 capacitive buttons and 4 sliders

Proximity sensing up to 5 cm (with onboard PCB trace)

Water tolerant performance with shield electrode

2.4V to 5.25 V operating voltage

Up to 28 GPIOs

I2C communication with master, slave, and multi-master configurations
Four digital blocks provide:

a Counter, timer, PWM, PRS, PWD (pulse width discriminator)

o SPI, UART, IRDA, and one-wire communication protocols

Single slope incremental ADC (with CSDADC)

EEPROM emulation

8-KB flash and 512-B RAM

Internal main oscillator up to 48 MHz with a 24-MHz system clock

Variety of packages: 16-SOIC, 20-SSOP, 28-SSOP, 32-QFN, and 56-SSOP
AEC qualified automotive grade parts - CY8C21334 and CY8C21534
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Figure 4-14. CapSense Controller CY8C21001 Schematic
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4.2.4.2 Universal CapSense Module Connector

The CY3280-21x34 has an expansion port, P2, designed to connect UCC module boards. The con-
troller board can be used with any of the Universal CapSense module boards. The boards can be
interfaced to the CY3280-21x34 via the 44-pin connector P2. The pin mapping for the port P2 is
shown in the following figure.

Figure 4-15. Universal CapSense Module Connector Schematic
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4.2.4.3 ISSP

ISSP is used to program the device using MiniProgl. Plug in the MiniProg device to the ISSP header
J3. The ISSP connector is also used to connect the 12USB bridge to communicate between the PC
and controller board. The pin mapping for the ISSP connector is shown in the following figure.

Figure 4-16. ISSP Header J3 Schematic
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XRES/INT (pin# 3 of ISSP header J3) is routed to either XRES or P1_5 pin of the CapSense control-
ler. The selection is made using J4 header.

Figure 4-17. XRES Pin Selection Header J4 Schematic
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4.2.4.5 Expansion Header

SPI and auxiliary 12C pins (P1_5, P1_7) of the CapSense controller are routed to the expansion
header J2.

Figure 4-18. Expansion Header J2 Schematic
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ICE-Cube Debug Connector

The ICE-Cube debugger allows to debug and view the content of specific memory locations. The
ICE-Cube debugger can be connected to the board through port P1. The following figure shows the
schematic view of the ICE-Cube debug connector.

Figure 4-19. ICE-Cube Debug Connector P1 Schematic
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Note The current revision of the kit has known issues with debugging and the connector is not pop-
ulated; see the release notes for the workaround.
Adjustable Regulator - VADJ

The CY3280-21x34 Universal CapSense Controller board has an onboard adjustable regulator.
Regulated 5-V output from LM117 is used as the source. The factory setting is 3.3 V.

VADJ being the output of LP387ES-ADJ, follows this equation:
VADJ =1.216 x (1 + Rx/ Ry)

Where,

Rx is the resistance between VOUT and ADJ terminal of regulator LP3875. From the schematic, Rx
corresponds to 8.87 KQ.

Ry is the resistance between ADJ and GND terminal of regulator LP3875. Load Ry is adjusted by
sending 12C commands via ISSP connector J3.

I2C command format to vary Ry.

W <7bit 12C Address = 0x2D> <0x00> <(Data Byte),5>
Where,

Ry = (Data Byte),o x (10K/256)
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4.2.4.8 Power LEDs

The LEDs are used to show the status of the controller board. LED D1 lights up when the board is
powered by any of the power sources. LED D2 lights up when the CapSense controller is powered.

Figure 4-20. LEDs D1 and D2 Schematic
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4.2.4.9 CMod
CMod is the test point provided on the CY3280-21x34 Universal CapSense Controller board to

probe voltage on capacitor C2.

Capacitor C2 popularly known as modulation capacitor (CMod) is one of the external component
required by the CapSense_CSD algorithm. The other component is the resistor Rb (R50).

For more details on CMod and Rb, see the CSD User Module datasheet.
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4.3 Board Accessories

43.1 CY3280-SLM Universal CapSense Linear Slider Module Board

CY3280-SLM board consists of five CapSense buttons, one linear slider (with 10 sensors), and five
LEDs. The module board can be connected to the Universal CapSense Controller board via a 44-pin
receptacle connector J1.

Shield traces on the board can be either connected to ground or to the shield electrode pin of the
CapSense controller. A 3-pin header J2 is used to select between ground and shield electrode.

The board also provides footprints for an optional I2C EEPROM and thermistor, which are not popu-
lated by default.

Figure 4-21. CY3280-SLM Universal CapSense Linear Slider Module Board
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Figure 4-22. CY3280-SLM Connected to CY3280-20x34 Universal CapSense Controller Board
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4.3.2 CY3280-BBM Universal CapSense Prototyping Module Board

The CY3280-BBM Universal CapSense Prototyping Module provides access to every pin routed to
the 44-pin connector on the attached UCC board. Use the prototyping module board with a Universal
CapSense Controller to implement additional functionality that is not part of other single-purpose

Universal CapSense module boards.
Figure 4-23. CY3280-BBM Universal CapSense Prototyping Module Board
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Figure 4-24. CY3280-BBM Connected to CY3280-20x34 Universal CapSense Controller Board
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4.3.3 CY3217-MiniProgl PSoC Programmer

CY3217-MiniProgl is an inexpensive programmer for PSoC devices. MiniProgl also supports all
programmable CapSense controllers. ISSP header J3 on the CY3280-Universal CapSense Control-
ler board is used to connect MiniProg1l.

Figure 4-25. MiniProgl Connected to CY3280-20x34 Universal CapSense Controller Board
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4.3.4 CY3240-12USB Bridge

The main purpose of the 12C-USB bridge is to test, tune, and debug programs that have an 12C
slave interface. It is also useful for data acquisition and regulation under PC control.

By default, the 12C-USB bridge is connected to the ISSP header J3 on the CY3280-20x34 Universal
CapSense Controller board.

Figure 4-26. 12C-USB Bridge Connected to CY3280-20x34 Universal CapSense Controller Board
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This section walks you through the high-level design process to open, build, program, and run code
examples using the CY3280-BK1 Universal CapSense Controller Kit.

5.1 My First CapSense (CY8C20x34) Project

This project demonstrates how to use the CapSense CSA_EMC User Module to scan buttons and
sliders on the CY3280-SLM module board. The CSA_EMC User Module scans all the buttons
continuously and stores the raw count, baseline, button on/off state, and slider centroid position in a
structure defined by 12C_REGS. This structure is exposed to an 12C master to allow reading by the
EzI2Cs User Module. LED User Modules are used to control LEDs based on detected finger touch.

Figure 5-1. Firmware Flow

Enable Global Interrupts
Clear All LED’s

12

Set 12C RAM Buffer

v
Start 12C
Start CSA_EMC
Initialize Baselines
Set Finger Thresholds

Loop Forever

Scan All Sensors
Update All Baselines
Check for active sensors

v
Update I2CRAM buffer with
CapSense Parameters
[RawCount, Baseline,
SensorMask, Slider Position]

v

Update LEDs
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5.1.1 Loading My First CapSense Project

1. Open PSoC Designer.
2. Inthe Start page, navigate to File > Open Project/Workspace.

3. Navigate to the project directory <Install_Directory>\CY3280-BK1\<version>\Firm-
ware.

4. Move the Firmware folder to a writable directory and then open it
5. Open the folder CY3280 20x34_SLM.
6. Double-click on CY3280_20x34_SLM.app.

The project opens in the Chip Editor view. All project files are in the Workspace Explorer.

Figure 5-2. PSoC Designer Chip Editor View

CY3280_20x34_SLM - PSoC Designer 5.4

File Edit Wiew Project  Interconnect  Buld Debug  Program  Tools  MWindow Help

NMEHS . THES @ GlF @B, HEF 0 @@k pl? E Timare @ e @ E K,
Global Resources - 0y3280 234 sim  » 8 X Start Page- Cy3280_20x34_slm [Chip]| main.c | v 4 b x |[Waorkspace Explorer rAX
Pawer Setting [ 4 5.0 £ 12MHz ~ 2 ERE R R - M
gIF'U-E:_Ck :%‘ZE::’ = — b | [ET Workspace Tv3280_20434_SLM [T project) ~
leep_Timer - Hz 25 CY3280_20x34_SLM [CYAC20434-1 2LK391)
SpsClk Source | Intemal 12_MHz -8 CY3280_20x34_SLM [Chi
e = C | 20:34_SLM [Chip]

Trip Yoltage [V 4.81% [5.00%]
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Watchdog Enab Dizable
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_ Irtemupttode  Low | £ = ESEEEMC
CPU_Clack [ [ LED.D
Selects the MBC clock speed, from 46.875 KHz to [ LED A
12 MHz. Denived from the SysClk Registers AfF. : | LED 2
[ LED_3
Parameters - C5A_EMC -3 X i L[ LED 4
| ; E Cr3280_20:34_SLM [Pinout]

Mame CS4_EMC

CV3280_2034_SLM
=& Source Files

. boot.asm ¥
Es | S
Workspace Explorer | Code Outlining

FingerThrezhold 130
NoizeThreshold - 35
Bazelinellpdate1 150
SettlingTime 160

Hysteresis 10 User Madules > 31X
Debounce 3 Ql dil ﬁ 9 B e i 5‘5. ® i
MegativeMoizeTl 35

4] User Modules -~

LowBaselineRes 50

o
Sensors dutares) Nisahlad [#-{_1 Amplifisrs

& 1 Cap Sensors

Name 2 2L

Indicates the mame used to identify this User t' LJ Digital Comm

odule instance B LJ Legacy

. G- Misc Digital

PinaLt - cy3280_20x34_sin 0 X| *il LJ ’:UTS ;
PO[0] Port_0_0, StdCPU, HighZ | +_: 3 R::o ocals

FO[1] LED_2Pin, StdCPU, Stronc—| +'| 8 Ters =
PRl ConEMCSS oL o ik :
Cutput

Ready.

51.2 Building My First CapSense Project
Select Build > Generate/Build 'CY3280_20x34_SLM Project.
Figure 5-3. Build Project

« CY32B0_20x34_SLM - PSoC Designer 5.4

File Edt “ew Project  Interconnect | Build | Debug  Program  Tools  Window  Help
i i Generate/Buid ! |_20%34_5LM' Projec] =
*__3 L_? Eal ‘.—,?h = G kefBuild 'C¥3280_20x34_SLM' P {4 F& 3
Global Resources - cy3280720x3475|m ~ 1 Generate/Build All Projects Shift+Fé
Power Setting [* 5.0V / 12MHz | Generate Configuration Files for 'CY3280_20x34_SLM' Project  Chrl+F6
CPU_Clock Syslhk/2
Sleep_Timer 512 Hz Generate Configuration Files far All Projects
SpsClk Source  Intemal 12_MHz & comple
TripWoltage [LVT 487 [5.004]
LD ThictleBach Disable Build 'C¥3280_20x34_SLM' Project F7
‘watchdog Enab Dizable Reebuild "C3280_20x34_5LM' Project
§ Interrupt Mode | Low Clzan 'CY3280_20%34_5LM Project
CPU_Clock
Selecks the MBC clock speed, from 46,875 KHz Show Last Build Report For 'CY3260_20x34_SLM' Praject  ChrH-Shift+F7
FALAIL Pyt e e s e
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PSoC Designer builds the project and displays comments in the Output window. When you see the
message that the project is built with O errors and 0 warnings, you are ready to program the device.

Figure 5-4. Output Window
Output

Show output from: [ Build - ]

847 bytes unused code deleted

idata dump at output 23280 2034 SLMidata
ROM 35% full. 3139 out of 8192 bytes used (does naot include absolute areas).
RAM 73%full. 278 bytes used (does not include stack usage)|

Buitt with ICCMBC STD VW7.05.00

CY3280_ 2034 _SLM - 0 emorls) 0 waming(z) 13:48:48

5.1.3 Setting up the Board
This section demonstrates the setup of CY3280-SLM with CY3280-20x34 Universal CapSense
Controller board.

1. Connect the CY3280-SLM board to the P2 receptacle connector of the CY3280-20x34 Universal
CapSense Controller boards.

2. In the CY3280-20x34 board, place jumper on header J1 to short pins 2 and 3. This setting allows
the CapSense controller to be powered from ISSP connector J3.

3. Inthe CY3280-20x34 board, place jumper on header J4 to short pins 1 and 2. This setting routes
the XRES pin of the CapSense controller to pin 3 of ISSP connector J3.

4. Inthe CY3280-SLM board, place jumper on header J2 to short pins 2 and 3. This setting con-
nects the shield traces on the CY3280-SLM board to ground.

5. Connect your computer to the CY3280-20x34 Universal CapSense Controller board's ISSP con-
nector J3 using MiniProgl and a USB cable.

Figure 5-5. Board Setup

=
8
=]
&
9 B
&

514 Programming My First CapSense Project

1. Open Program Part in PSoC Designer by selecting Program > Program Part.
2. In the Program Part window:

a. Select MiniProgl in the Port Selection box.

b. Set Acquire Mode to Power Cycle.

c. Set Verification to ON. This ensures that the downloaded checksum matches the actual
checksum.
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d. Set Power Settings to 5.0V.
e. Click the program arrow to program the device.

3. Wait until programming is completed.

Figure 5-6. Program Part View

# Program Part

Hex file path:

C:AProgram FileshCypresshCy' 3280-BK1CodeE wamples T 3280_2

Froaramming Settings

Port Selections | MINIFrog1 /882158081303 | | 4IP

Acauire Mode: () Reset (*) Power Cycle

Werification: Con © oK

FPower Settings: @

MINI Yersion 1.79 .

-------- MEEFSEEAN  Comveced

5.1.5 Running My First CapSense Project

1. Power the board at 5 V using MiniProg1 or from any of the sources listed in Power Sources on
page 31.

2. Touch the linear slider on the CY3280-SLM module board. The corresponding LEDs on the
CY3280-SLM board light up.

3. Touch a button. The corresponding LED on the CY3280-SLM module board lights up. Multiple
buttons can be touched at the same time. The linear slider and buttons can also be used simulta-
neously.

Figure 5-7. LED2 Glows when Linear Slider is Touched

5.1.6 Reading CapSense Data over 12C

1.

Connect your computer to the CY3280-20x34 Universal CapSense Controller board's ISSP con-
nector J3 using 12C-USB bridge and a USB cable.

Go to Start > Cypress > Open Bridge Control Panel.
Note Bridge Control Panel is installed as part of the PSoC Programmer installation process.
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3. Select the device from the Connected 12C/SPI-USB converters: window and click on the Con-
nect/Disconnect button.

4. Power the CY3280-20x34 CapSense Controller board at 5 V.

5. Select File > Open File. Load CY3280-20x34.iic from <Install_Directory>\CY3280-
BK1\<version>\Firmware\CY3240_12USB_Configuration files.

6. Select Charts > Variable Settings. Load CY3280-20x34.ini from
<Install_Directory>\CY3280-BK1\<version>\Firm-
ware\CY3240_12USB_Configuration files. Click OK to return to the main window.

Figure 5-8. Bridge Control Panel View

g Bridge Control Panel

File  Editor  Chart  Execute  Tools  Help
FEEE=R L EERE
Editor IEhart ITahIe File

JT2C Write <Slave Address> <0ffset> <Sensor Index = Sensor#>
JSensor# = 00 for EBITHD

dd for BITNHL
05 for SLD#H#O

ER
s Sensor#
s Sensor#

;Sensor# = OF for SLD#HS
W 04 00 00 ; T2C Write <S5lave Address = (4> <0ffset = 0> <Fensor Index = 0O

JI2C Read <Slave Address> <Sensor Index, 8Shits> <RawCount, 16bits> <Baseline, 16
R 04 @Sensor Index @lRawCount EO0RawCount ElBaseline @0Baseline @ButtonStatus @Sl:

< >

Select Port in the PortList, then try to connect
Opening Port

Successfully Connected to Bridge/89590FB5380A
USB2IIC Bridge version 1.35

Connect/Disconnect

Pover Pratacol
O +33v

T— Send all strings: [] Connected 12C/SPI-USE converters:
’ ®H888t ]L:LISt ISEnd ] Repeat count: Eridge.! 4
[=] @] Scan period, ms: oS I @ I =‘ Toggle Power
L

[ 1:1 | syntaxiok I {1 Connected ) [NSARSREREEN vo:oo:: -

7. Sample data read:
a. Reading raw count and baseline of P1[6]/BTNO:
i. Send 12C write instruction W 04 00 00 once.

ii. Press the Repeat button to send the following 12C read instruction continuously
R 04 @Sensor_Index @1RawCount @ORawCount @lBaseline @0Baseline
@ButtonStatus @SHiderPosition.

iii. Go to the Chart tab to view raw count and baseline of P1[6]/BTNO.
b. Reading raw count and baseline of P1[4]/SLDO:
i. Send 12C write instruction W 04 00 05 once.

ii. Press the Repeat button to send the following 12C read instruction continuously
R 04 @Sensor_Index @1RawCount @ORawCount @lBaseline @0Baseline
@ButtonStatus @SHiderPosition.

iii. Go to the Chart tab to view raw count and baseline of P1[4]/SLDO.
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See 5.1.6.1 CapSense Sensor Data for information on how to view raw count and baseline data of
other CapSense button and slider segments.

5.16.1 CapSense Sensor Data

The CY8C20x34 board firmware updates the raw count and baseline value of a CapSense sensor to
the 12C register continuously. The contents of the 12C register are read and output to the GUI when-
ever an I2C read command is sent to the slave. By default, the output is always Button 0 data.

To view the raw count and baseline of any other CapSense sensor, the sensor number or the sensor
index should be specified to the slave using a I12C write command.

The write command syntax is as follows:
W <Slave Address> <0Offset> <Sensor_Index>

Slave_Address - 04 (constant)
Offset - 00 (constant)

Sensor_Index - See Table 5-1

Table 5-1. Sensor Index

No. Pinout Bust:;r:rl]selri]ctier Sensor_Index
1 P1[6] BTNO 0
2 P1[3] BTN1 1
3 P3[3] BTN2 2
4 P2[1] BTN3 3
5 P2[3] BTN4 4
6 P1[4] SLDO 5
7 PO[6] SLD1 6
8 PO[4] SLD2 7
9 PO[2] SLD3 8
10 P2[6] SLD4 9
11 P2[4] SLD5 0A
12 P2[2] SLD6 0B
13 P2[0] SLD7 ocC
14 P3[2] SLD8 oD
15 P3[0] SLD9 OE

For example, to read the Button 2/P3[3] data, first send a write command as follows:
W 04 00 02

Then, read the data by sending the read command
R 04 @Sesnor_Index @1RawCount @ORawCount @1Baseline @0BaselLine @ButtonSta-
tus @SliderPosition

Similarly, to read the Slider 6/P2[2] data, send the write command as follows:
W 04 00 OB

Then, read the data by sending the read command
R 04 @Sesnor_Index @1RawCount @ORawCount @1Baseline @OBaselLine @ButtonSta-
tus @SliderPosition
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5.1.7 Tuning for Overlay

The code example accompanying the kit is not tuned with overlay. For the code example to work
with the 1.5-mm and 3-mm acrylic overlays, the CSA_EMC User Module parameters must be
adjusted. See the Tuning section of the user module datasheet for details; to select this datasheet,
right-click on the CSA_EMC User Module in Workspace Explorer.

5.2 My First CapSense (CY8C21x34) Project

This project demonstrates how to use the CapSense CSD User Module to scan buttons and sliders
on the CY3280-SLM module board. The CSD User Module scans all the buttons continuously and
stores the raw count, baseline, button on/off state, and slider centroid position in a structure defined
by I12C_REGS. This structure is exposed to an I12C master to allow reading by the EzI2Cs User
Module. LED User Modules are used to control LEDs based on detected finger touch.

Figure 5-9. Firmware Flow
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5.2.1 Loading My First CapSense Project

1.
2.
3.

4,
5.
6.

Open PSoC Designer.

In the Start page, go to File > Open Project/Workspace.

Navigate to the project directory <Install_Directory>\CY3280-BK1\<version>\Firm-
ware\.

Move the Firmware folder to a writable directory and then open it

Open the folder CY3280 21x34 SLM.

Double-click CY3280_21x34_SLM.app.

The project opens in the Chip Editor view. All project files are in the Workspace Explorer.

Figure 5-10. PSoC Designer Chip Editor View

File Edit Wew Project Interconnect Build Debug  Program  Tools  ‘Window  Help
NEHS ., B 5\ EFfd B 0 E o5, N EE7 @0 - &2 ») 4 [ ,
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24 MHz. Derived from the SysCle. This setting a

Parametars - CS0 >0 X

Bassinelpdate] an | ‘Workspace Explorer | Code Cutlining
Sensors Autores: Disabled = =
Hysteresiz 10 - User Modules > O X
[, 2 ELEEET LT )
NegallveHU\seTl i) ‘ﬂ e —
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Granninn Gneed Normal 2] -3 ADCs

Hame -1 Amplifiers

Indicates the name used to identify this User &‘ '—-‘ Cap Jensors

- Counters

Module instance
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glzgfﬁ;: 2l @:3 i ——— M = ST Workspace TY3280_21/M_5LM 1 projec]
VC1=SysChkM 16 EE E i | EE =1 Y CY3280_2134_SLM [CYBLZ1434-24LFX]
VEIZWOIN 16 foe | = | = -8 Cr3za0 21434 SLM [Chip]
VO3 Souce | WCZ =5 %_} - &l Cr3280 21234 SLM [Finou]

+ — B[ CY3280_21434_5LM

L3 Divider 256
Sy_s[:!k _Sou_rc:e : Intg_mal _24_7MH;

o el il - |

Name CsD ~

FingerThreshald ' 130
NoiseThieshold | 35

- Digital Comm
-] Legacy
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PO[1] LED_2Pin, StdCPU, Stionc— -5 Power Management

P[00 Ao e =
Dukput

Feady,

5.2.2 Building My First CapSense Project
Select Build > Generate/Build CY3280_21x34_SLM Project.

Figure 5-11. Build Project

& CY3280_21x34_SLM - PSoC Designer 5.4

File  Edit Miew Project Interconnect | Build | Debug Program Tools  Window  Help

’__] Lj H ﬂ i E ﬁ ‘:?h @ Generate/Build 'CY3280_21x34_SLM' Project F&
Glabal Resources - cy3.286_.21x?;4_sim ~ 1 Generate/Build Al Projects Shift+Fé

Pawer Seting[* 5.0V / 24MHz o Generate Configuration Files for 'CY3280_21x34_SLM Praject  Chrl+Fs

CPU_Clock SysClkA1

Sleep_Timer 512 Hz Generate Configuration Files For All Projects

WC1=5psClk/N 16 F)

WC2=WC1/M 16 - - .

S tie Vi) Build 'C¥3280_21x34_SLM' Project F7

WC3 Divider 256 Rehuild 'CYAFAN 21%34 SIM' Prodect
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PSoC Designer builds the project and displays comments in the Output window. When you see the
message that the project is built with O errors and 0 warnings, you are ready to program the device.

Figure 5-12. Output Window
Output
Show output from: | Build -

jdata dump at output /CY3280_21x34_SLM.idata
ROM 459% full. 3557 out of 81592 bytes used (does not include absolute arsas).
RAM 37% full. 233 bytes used (does not include stack usage).

Built with ICCMBC STD V7.05.00

C3280 2134 SLM - 0 emon(z) 0 waming(s) 13:53:24

Output

5.2.3 Setting up the Board

This section demonstrates the setup of CY3280-SLM with CY3280-21x34 Universal CapSense
Controller board.

1. Connect the CY3280-SLM board to the P2 receptacle connector of the CY3280-21x34 Universal
CapSense Controller boards.

2. Inthe CY3280-21x34 board, place jumper on header J1 to short pins 2 and 3. This setting allows
the CapSense Controller to be powered from ISSP connector J3.

3. Inthe CY3280-21x34 board, place jumper on header J4 to short pins 1 and 2. This setting routes
the XRES pin of the CapSense controller to pin 3 of ISSP connector J3.

4. Inthe CY3280-SLM board, place jumper on header J2 to short pins 2 and 3. This setting con-
nects the shield traces on the CY3280-SLM board to ground.

5. Connect your computer to the CY3280-21x34 Universal CapSense Controller board's ISSP con-
nector J3 using MiniProg1l and a USB cable.

Figure 5-13. Board Setup
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5.24 Programming My First CapSense Project

1. Open Program Part in PSoC Designer by selecting Program > Program Part.
2. In the Program Part window:

a. Select MiniProg1l in the Port Selection box.

b. Set Acquire Mode to Power Cycle.

c. Set Verification to ON. This ensure that the downloaded checksum matches the actual
checksum.

d. Set Power Settings to 5.0V.
e. Click the program arrow to program the device.
3. Wait until programming is completed

Figure 5-14. Program Part View
® Program Part

Hes file path:
C:"Program Filesh\CypresshCr'3280-BE 14 CodeE sampleshCy'3280_2

Frogramming Settings ——

Port Selection: | MINIProg1/882158081303 |+ | || 4/P
Acguie Mode: () Resst (3) Power Cycle
Yerification: ) On =) 0ff
Power Settings: @
MINI Version 1.79 —
[ L&
-------- WS corvecsd

5.2.5 Running My First CapSense Project

1. Power the board at 5 V using MiniProgl or from any one of the sources listed in Power Sources
on page 31.

2. Touch the linear slider on the CY3280-SLM module board. The corresponding LEDs on the
CY3280-SLM board light up.

3. Touch a button. The corresponding LED on the CY3280-SLM module board lights up. Multiple
buttons can be touched at the same time. The linear slider and buttons can also be used simulta-
neously.

Figure 5-15. LED2 Glows when Linear Slider is Touched
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5.2.6 Reading CapSense Data Over 12C
1. Connect your computer to the CY3280-21x34 Universal CapSense Controller board's ISSP con-
nector J3 using the 12C-USB bridge and a USB cable
2. Goto Start > Cypress > Open Bridge Control Panel.
Note Bridge Control Panel is installed as part of the PSoC Designer installation process.

3. Select the device from the Connected 12C/SPI-USB converters: window and click on the Con-
nect/Disconnect button.

4. Power the CY3280-21x34 CapSense Controller board at 5 V.

5. Select File > Open File. Load CY3280-21x34.iic from <Install_Directory>\CY3280-
BK1\<version>\Firmware\CY3240_ 12USB_Configuration files.

6. Select Charts > Variable Settings. Load CY3280-21x34.ini from
<Install_Directory>\CY3280-BK1\<version>\Firm-
ware\CY3240_ 12USB_Configuration files. Click OK to return to the main window.

Figure 5-16. Bridge Control Panel View

P Bridge Control Panel
File  Editor  Chart  Execute  Tools  Help
BEE SR CE | BEER
Edior |Chart | Table | Fie

;I2C_Write <Slave Address> <0ffset> <Sensor_Index = Sensor#>
;Sensor# = 00 for EBTWHO

04 for BITI#4
05 Ffor SLD#O

ER
s Sensor#
;Sensor#

;Sensor# = OF for SLD#HS
W 04 00 00 ; T2C Write «<S5lave Address = (0dx «<0ffset = (= <Sensor Index = 0>

;T2C¢ Read <Elave Address> <Sensoy Index, 8Sbits> <RawCount, I1bbits> <Baseline, 16
R 04 @Sensor Index @1lRawCount E0RawCount @lBaseline @O0Baseline @ButtonStatus @51

< >

Select Port in the PortlList, then try to connect
Opening Port

Successfully Connected to Bridge/B9590FB5380A
USB2IIC Bridge version 1.35

Connect/Disconnect

gfwer Pratocol
+5.00 @® 12C
O 3

@ P> Toggle Power
o Tsmaxiox [ | Connected | NGEEHETEANN volag=: -

0

— ings: [
’ @ Reset ] - List ] ﬁSend ] ::nd al stnng.s =
peat count: -CH ride 3
[=] @Hepeat D fle Scan period, ma: |

7. Sample data read:
a. Reading raw count and baseline of P1[6]/BTNO:
i. Send 12C write instruction W 04 00 00 once.

ii. Press the Repeat button to send the following 12C read instruction continuously
R 04 @Sensor_Index @1RawCount @ORawCount @lBaseline @0Baseline
@ButtonStatus @SliderPosition.

iii. Go to the Chart tab to view raw count and baseline of P1[6]/BTNO.
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b. Reading raw count and baseline of P1[4]/SLDO:

i. Send 12C write instruction W 04 00 05 once.

ii. Press the Repeat button to send the following 12C read instruction continuously
R 04 @Sensor_Index @lRawCount @ORawCount @1Baseline @OBaseline
@ButtonStatus @SliderPosition.

iii. Go to the Chart tab to view raw count and baseline of P1[4]/SLDO.

Note See CapSense Sensor Data on page 46 for information on how to view raw count and

baseline data of other CapSense button and slider segments.

5.2.7 Tuning for Overlay

The code example accompanying the kit is not tuned with overlay. For the code example to work
with the 1.5-mm and 3-mm acrylic overlays, the CSD User Module parameters must be adjusted.
See the Tuning section in the user module datasheet for details; to select the datasheet, right-click
on the CSD User Module listed in Workspace Explorer.

5.3 Proximity Sensing Project (CY8C21x34)

This project demonstrates how to implement proximity sensing using a wire loop. When the user's
hand moves towards the wire loop, the "Status" variable is set and when the hand moves away from
the sensor, it gets reset. This can be observed on Bridge Control Panel (BCP).
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Figure 5-17. Firmware Flow
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Is proximity
sensor active?

A

Reset status flag
to indicate the
absence of hand

Set status flag to
indicate the
presence of hand

5.3.1 Loading Proximity Sensing Project
1. Open PSoC Designer™
2. Inthe Start page, go to File > Open Project/Workspace

3. Navigate to the project directory <Install_Directory>\CY3280-BK1\<version>\Firm-
ware\

4. Move the Firmware folder to a writable directory and then open it
5. Open the folder Proximity CY3280_21x34
6. Double-click Proximity _CY3280_21x34.app

The project opens in the Chip Editor view. All project files are in the Workspace Explorer.
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Figure 5-18. PSoC Designer Chip Editor View

« Proximity_CY3280_21x34 - PSoC Designer 5.4
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L?Sijcj::;tsl?:nrlzme used to identify this Ulser User Modulss L1 x
| EE : B ¥ y
Pinaut - I.:‘roximiEy_K.BA -1 X ﬂj User Modules T
FO[0] CSD5WO, AnaloghdUxlng & - ADCS
PO[1] Part_0_1, StdCPU, High - Amplifiers
FO[2] Fort_0_2, 5tdCPLU, High: - Cap Sensors
FO[3] C5DCapacitor, AnaloghdL — ] Counters
PO4] Part_0_4, StdCPU, High b1 Digital Comm
PO[5] Port_0_5, StdCPU, High [ Legacy -
PO[E] Part_0_&, StdCPU. High b Misc Digital
PO[7] Part_0_7, StdCPU, High b MUs
F1[0] Ezl2Cs50, |20 5D, O B[ Power Management
F P11 Fol2Cs50 120 S0 Mne G- Prokocols B
Cubpk
Ready,

5.3.2

Building Proximity Sensing Project

Select Build > Generate/Build Proximity _CY3280_21x34 Project.

Figure 5-19. Build Project

‘ Proximity CY32B0_21x34 - PSoC Designer 5.4

Pu;wer Sétting [‘;Fcc / Sj,lsl:lk freq ]
Selects the nominal operation voltage and

File Edit Wiew Project  Interconnect
NMEZdd. THE % &
Global Resources - Proximity_| KBA « X
Fawer Settlng [ B0/ 24MH2 »

CPU_Clock. SpslClk/2

Sleep Timer 512 _Hz

WC1=SpzClks/N 16

WC2=WC1/M 16

W3 Source W2

W3 Divider 206 3

Syztem Clock [SyzClk] source, from which ma...

ELIW| Debug  Program  Tools  Sindow  Help
‘ Generate/Build 'Proximity CY3280_21x34' Project F&
Generate/Build All Prajects Shift+Fa
|f Generate Configuration Files for 'PL CY3280_F1x34' Project Chrl+Fa
Generate Configuration Files For Al Projects
| &
Build 'Procimity _CY3280_21x34' Project F7

Rebuild ‘Proximity_CY3280_21:x34' Project
Clean 'Proximity_CY3280_21x34' Project

Shiow Last Build Report For ‘Praximity_CY3280_21x34' Projedtrl+Shift+F7

PSoC Designer builds the project and displays comments in the Output window. When you see the
message that the project is built with O errors and 0 warnings, you are ready to program the device.
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Figure 5-20. Output Window

Output
Show output from: [ Build - ]

idata dump at output/Prosimity_CY 32802134 idata
ROM 25% full. 2017 out of 8152 bytes used (does not include absolute areas).
RAM 20% full. 50 bytes used (does not include stack usage).

Buitt with ICCMBC STD V7.05.00

Proodmity_CY3280_21x34 - 0 emoris) 0 waming(s) 13:55:26

5.3.3 Setting up the Board

1. Inthe CY3280-21x34 board, place the jumper on header J1 to short pins 2 and 3. This setting
allows the CapSense controller to be powered from ISSP connector J3.

2. In the CY3280-21x34 board, place the jumper on header J4 to short pins 1 and 2. This setting
routes the XRES pin of the CapSense controller to pin 3 of the ISSP connector J3.

3. Connect your computer to the CY3280-21x34 Universal CapSense Controller board's ISSP con-
nector J3 using MiniProgl and a USB cable. Connect a wire loop (10-cm circumference) to PO[0]
on the P2 connector of the CY3280-21x34 kit as shown in the Figure 5-21.
Note: MiniProg3 can be used as an alternative to MiniProg1l (to program) the CY3240 12USB
board (12C USB bridge).

Figure 5-21. MiniProgl Connection

534 Programming Proximity Sensing Project

1. Open Program Part in PSoC Designer by selecting Program > Program Part.
2. In the Program Part window:

a.
b.
c.

Select MiniProg3 in the Port Selection box.
Set Acquire Mode to Power Cycle.

Set Verification to ON. This ensures that the downloaded checksum matches the actual
checksum.

. Set Power Settings to 5.0 V.
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e. Click the program arrow to program the device.
3. Wait until programming is completed

Figure 5-22. Program Part View

Hex file path:
ChlUsers‘\as'\Documents\CY3280_2 134 SLMMCY 3280 21x34 &

Programming Settings

Port Selection: MINIProg1/832158082E23 V]

Acquire Mode: ") Resst @ PowerCycle

Verfication: @ On = Off

Power Settings:

Program Finished at 3:45:26 PM

5.3.5 Verify Proximity Sensing Project and Read Data over 12C

Follow these steps to set up the Bridge Control Panel for reading the CapSense parameters.

1. Connect your computer to the CY3280-21x34 Universal CapSense Controller board's ISSP con-
nector J3 using the CY3240 I2USB (I12C-USB bridge) and a USB cable, as shown in Figure 5-23.

Figure 5-23. Connect Using CY3240 12USB

2. Goto Start > Cypress > Open Bridge Control Panel.

Note Bridge Control Panel is installed as part of the PSoC Designer installation process.
3. Select the MiniProg3 device from the Connected 12C/SPI-USB converters: window.
4. Power the CY3280-21x34 CapSense Controller board at 5 V.
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5. Select File > Open File. Load CY3280-21x34-ProxDet.iic from
<Install_Directory>\CY3280-BK1\<version>\Firmware\CY3240_ I12USB_Configuration
files.

6. Select Charts > Variable Settings. Load CY3280-21x34-ProxDet.ini from
<Install_Directory>\CY3280-BK1\<version>\Firmware\CY3240_ I12USB_Configuration
files

7. Click OK to return to the main window.

Figure 5-24. Bridge Control Panel View

5o Bridge Control Panel

File  Editor  Chart  Execute  Tools  Help
EHE SRR EIEEE

Editor | Chart | Table | File

JT2C Write <Slave Address’> <0ffset Address> |
W 04 00 ;T2C Write <S5lave Address = (d= <0ffset = 00>

JI2C Read <Slave Address> <RawCount, 16bits> <Baseline, léhits> <Diffcount, 16bits> <Status, 8bits>
R 04 @lRawCount @0RawCount @l1lBaseline @0Baseline @1Diffcount #0Diffcount @status

8. Keep the cursor on the first command (w 04 0) in the Editor window and press Enter.
9. Keep the cursor on the second command line in the Editor window and click Repeat.
10.Click the Chart tab on the BCP and select the plot Status listed in the top right corner.

11. Bring the hand towards the wire loop and observe in the BCP that the status variable becomes '1'

as shown in Figure 5-25.
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Figure 5-25. Status Variable on Bridge Control Panel

g Bridge Control Panel

Code Examples

File  Editor  Chart  Execute  Tools  Help
BEE|SERIOEIEER
| Editor | Chat | Table | File
t )\ Select Al
Presence of Hand [] — RawCount
Ll Bazeline
[] — DiffCount
075 Status
0.5
0.25
Absence of Hand
(&) Linear
l O Logln
g e e e e e e . ENES
12870 13610 14250 14890
Flags Chart Quality Chart Mode
gf0 gfl gf2 gf3 gfd of5 of6 gf7 gf8 of9 ogfA gfB gfC ofDd ofE gfF O High @ Lire Plat
& Momal () Bar Graph

12. Deselect the Status plot and select the plot RawCount to see the profile of Raw counts shown in

Figure 5-26.
Figure 5-26. Raw Count Profile

[ Bridge Control Panel
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5.3.6 Proximity Tuning Steps

Use the following steps to tune the CapSense system for proximity detection.

1. Determining Proximity Distance
For reliable proximity detection, the SNR needs to be 5:1. Follow these steps to determine the

proximity distance.

a.
b.

Find the noise count.

Calculate the signal count that is required to achieve a 5:1 SNR (Signal Count = 5*Noise
Count).

Bring the hand towards the wire sensor until the signal count reaches the value calculated in
Step (b). The present distance between the wire sensor and the hand is called the proximity

distance.
Note: Refer to Section 4.1.1, "Signal, Noise, and SNR" in the CY8C21x34/B CapSense
Design Guide for more information about SNR calculation.

2. Determining CapSense Sigma Delta (without Prescaler) User Module (UM) parameters for prox-
imity detection. The following steps can be used to determine the CapSense Sigma Delta (CSD)
UM parameters for proximity detection.

a.
b.

Find the peak Difference Count from the BCP when there is no hand present.

Find the Peak Difference Count from the BCP when the hand is present at the proximity dis-
tance calculated above.

Set the Finger Threshold parameter to 60 percent of the Difference Count observed in Step
b (when the hand is present).

Set the Noise Threshold parameter to 40 percent of the Difference Count observed in Step a
(when no hand is present).

Set Baseline Update Threshold to 100.
Set Sensor Autoreset to Disabled.

Set Hysteresis to 15 percent of the Difference Count observed in Step b (when the hand is
present).

Set Negative Noise Threshold equal to Noise Threshold.
Set Scanning Speed to Slow.

Set Resolution to 16.

Set Ref Value to 1.

Leave all the other parameters as their default values.

Note: Click on the tab Table in the BCP to observe the Difference count values.
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The schematic, board layouts, and bill of materials (BOM) are available on the kit DVD or at the fol-
lowing location: <Install_directory>:\Cypress\CY3280-BK1\<version>\Hardware.

A.l CY3280-20x34 Universal CapSense Controller Board
Al1l Board Schematic
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A.l.2 Board Layout
Figure A-1. Primary Side
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Figure A-2. Secondary Side
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A.1.3 Bill of Materials
Iltem | Qty. Reference Part Manufacturer Mfr. Part No.
1 1 CY3280-20x34 PCB Cypress
2 2 C4,C1 CAP 10000PF 16V CERAMIC 0402 SMD | Panasonic - ECG ECJ-0EB1C103K
3 1 Cc2 CAP 3900PF 50V CERAMIC 0805 SMD Panasonic - ECG ECJ-2VB1H392K
4 4 C3,C5,C6,C7 CAP 10UF 16V TANTALUM 10% 3216 AVX TAJA106KO016R
5 1 D1 LED GREEN Clear 0805 SMD LITE-ON Inc LTST-C170GKT
6 1 D2 LED AMBER Clear 0805 SMD LITE-ON Inc LTST-C170AKT
7 3 D3,D4,D5 DIODE SCHOTTKY 0.5A 20V SOD-123 Fairchild Semiconductor | MBR0520L
8 1 J3 CONN HEADER 5POS 0.1 VERT KEYED | Molex 22-23-2051
9 2 J1,J4 CONN HEADER VERT 3POS .100 30AU | AMP Division of TYCO 87220-3
10 1 J5 CONN 2.1MM PWRJACK RT ANGLE PCB | Switchcraft RAPC722X
11 1 P2 CONN FMALE 44POS DL .1" R/A GOLD | Sullins Electronics Corp. | PPPC222LJBN-RC
12 23 |R1,R4,R7,R8,R9,R10,R11 |RES 560 OHM 1/16W 5% 0402 SMD Yageo Corporation RC0402JR-07560RL
R12,R16,R17,R15,
R20,R21,R22,R23,R24,R25
R26,R27,R28,R29,R30,R32
13 4 R2,R5,R13,R18 RES 300 OHM 1/16W 5% 0402 SMD Yageo Corporation RC0402JR-07300RL
14 4 R3,R6,R14,R19 RES ZERO OHM 1/16W 5% 0603 SMD Yageo Corporation RC0402JR-070RL
15 5 R31,R41,R42,R43,R44 RES 100 OHM 1/16W 5% 0402 SMD Rohm MCRO01MZPJ101
16 1 R33 RES 8.87K OHM 1/16W 1% 0402 SMD Panasonic - ECG ERJ-2RKF8871X
17 2 R38,R39 RES 1K OHM 1/10W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ102V
18 4 R34,R35,R36,R37 RES 56k OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ563X
19 2 R49,R50 RES ZERO OHM 1/16W 0402 SMD Panasonic - ECG ERJ-2GEOROOX
20 3 TP7,TP11,TP15 EEiEEOINT 43 HOLE 65 PLATED Keystone Electronics 5001
21 5 TP1,TP3,TP6,TP10,TP13 TEST POINT 43 HOLE 65 PLATED RED | Keystone Electronics 5000
22 1 TP8 giiLF(;(élNT 43 HOLE 65 PLATED Keystone Electronics 5003
23 1 Ul IC, 48 QFN PSoC OCD Cypress Semiconductor | CY8C20000
24 1 u2 IC REG LDO 1.5A ADJ VOLT TO263-5 National Semiconductor hT)sS;SES'ADJ/
25 1 U3 IC DGTL POT SPI 10K 10-MSOP Analog Devices Inc AD5161BRMZ10
26 1 U4 IC REG 5.0V 800MA LDO SOT-223 National Semiconductor | LM1117MPX-5.0
Do Not Populate
27 1 BH1 BATTERY HOLDER 9V Female PC MT Keystone Electronics 594
28 1 BH2 BATTERY HOLDER 9V Male PC MT Keystone Electronics 593
29 1 c8 CAP 330PF 100V CERAMIC X7R 0603 Panasonic - ECG ECJ-1VB2A331K
30 1 P1 g%\'l_:\_:_ i\ll\l‘léleés MOD JACK UNSHIELD AMP Division of TYCO 557785-1
31 1 R40 RES 5k OHM 1/8W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ512V
32 R45,R46,R47,R48 RES 1K OHM 1/10W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ102X
33 |1 | CONN HEADER VERT 6POS .100 TIN i'\g;"eX/W aldom Electron- | ; »8-4060
34 1 TP14 ;EiEKPOINT 43 HOLE 65 PLATED Keystone Electronics 5001
35 4 TP2,TP5,TP9,TP12 TEST POINT 43 HOLE 65 PLATED RED | Keystone Electronics 5000
Special Jumper Installation Instructions
36 1 Install jumper across pins 2 and 3 of J1 Sullins Electronics Corp. | STC02SYAN
37 2 Install jumper across pins 1 and 2 of J4 Sullins Electronics Corp. | STC02SYAN
Install On Bottom of PCB As Close To Corners As Possible
38 | 4 | n/a BUMPER CLEAR.370X.19" CYLINDER Richco Plastic Co RBS-35
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A.2 CY3280-21x34 Universal CapSense Controller Board

A2.1 Board Schematic
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Board Layout

A.2.2

Figure A-3. Primary Side
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Figure A-4. Secondary Side
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A.2.3 Bill of Materials

Item | Qty. Reference Part Manufacturer Mfr. Part No.
1 1 CY3280-21x34 PCB Rev** Cypress Semiconductor | PDC-9414**

2 2 C1,C4 CAP 10000PF 16V CERAMIC 0402 SMD Panasonic - ECG ECJ-OEB1C103K
3 1 Cc2 CAP 10000PF 50V CERM CHIP 0805 Panasonic - ECG ECJ-2VB1H103K
4 4 C3,C5,C6,C7 CAP 10UF 16V TANTALUM 10% 3216 AVX TAJA106KO016R

5 1 Cc8 CAP CERAMIC 10UF 25V X5R 1206 Panasonic - ECG ECJ-3YB1E106M
6 1 D1 LED GREEN Clear 0805 SMD LITE-ON Inc LTST-C170GKT

7 1 D2 LED AMBER Clear 0805 SMD LITE-ON Inc LTST-C170AKT

8 4 D3,D4,D5,D6 DIODE SCHOTTKY 0.5A 20V SOD-123 Fairchild Semiconductor | MBR0520L

9 2 J1,J4 CONN HEADER VERT 3POS .100 30AU AMP Division of TYCO 87220-3

10 |1 J3 CONN HEADER 5POS 0.1 VERT KEYED | Molex 22-23-2051

11 1 J5 CONN 2.1MM PWRJACK RT ANGLE PCB | Switchcraft RAPC722X

12 |1 P2 CONN FMALE 44POS DL .1" R/A GOLD Sullins Electronics Corp. | PPPC222LJBN-RC

R1,R4,R7,R8,R9,R10,R11,
13 |22 E;irlezsR};iGIles?R};go RES 560 OHM 1/16W 5% 0402 SMD Yageo Corporation RC0402JR-07560RL
R27,R28,R29,R30,R32

14 |4 R2,R5,R13,R18 RES 300 OHM 1/16W 5% 0402 SMD Yageo Corporation RC0402JR-07300RL
15 6 R3,R6,R14,R19,R51,R52 | RES ZERO OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEOROOX
16 5 R31,R41,R42,R43,R44 RES 100 OHM 1/16W 5% 0402 SMD Rohm MCR01MZPJ101
17 1 R33 RES 8.87K OHM 1/16W 1% 0402 SMD Panasonic - ECG ERJ-2RKF8871X
18 2 R38,R39 RES 1K OHM 1/10W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ102V
19 1 R49 RES ZERO OHM 1/16W 5% 0603 SMD Panasonic - ECG ERJ-3GEYOROOV
20 |4 R34,R35,R36,R37 RES 56k OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ563X
21 3 TP7,TP11,TP15, TEST POINT 43 HOLE 65 Plated BLACK Keystone Electronics 5001

22 |5 TP1,TP3,TP6,TP10,TP13 | TEST POINT 43 HOLE 65 Plated RED Keystone Electronics 5000

23 |1 TP8 TEST POINT 43 HOLE 65 Plated ORANGE | Keystone Electronics 5003

24 |1 u2 IC REG LDO 1.5A ADJ VOLT TO263-5 National Semiconductor | LP3875ES-ADJ/NOPB
25 1 U3 IC DGTL POT SPI 10K 10-MSOP Analog Devices Inc AD5161BRMZ10
26 |1 U4 IC REG 5.0V 800MA LDO SOT-223 National Semiconductor | LM1117MPX-5.0
27 1 us IC, 56 SSOP PSoC OCD Cypress Semiconductor CY8C21001

28 1 R50 RES 7.68K OHM 1/10W 1% 0603 SMD Panasonic - ECG ERJ-3EKF7681V
Do Not Populate

29 1 BH1 BATTERY HOLDER 9V Female PC MT Keystone Electronics 594

30 |1 BH2 BATTERY HOLDER 9V Male PC MT Keystone Electronics 593

31 |1 |c9 CAPACITOR 1.0UF/16V TEH SER SMD Panasonic - ECG ECS-H1CY105R
32 1 P1 gl%l\ll-l’tll' i‘:\?gLBEg MOD JACK UNSHIELD AMP Division of TYCO 557785-1

33 1 u6 IC DGTL POT SPI 10K 10-MSOP Analog Devices Inc AD5161BRMZ10
34 1 L1 INDUCTOR 2.2UH 1000MA 1812 10% EPCOS Inc B82432T1222K
3B |1 R40 RES 5.1K 0805 SMD Panasonic - ECG ERJ-6GEYJ512V
36 1 C10 CAP 330PF 100V CERAMIC X7R 0603 Panasonic - ECG ECJ-1VB2A331K
37 |4 R45,R46,R47,R48 RES 1.0K OHM 1/16W 5% 0402 SMD Yageo Corporation RC0402JR-071KL
38 |1 J2 CONN HEADER VERT 6POS .100 TIN Molex/Waldom Electronics | 22-28-4060

39 |4 TP2,TP5,TP9,TP12 TEST POINT 43 HOLE 65 PLATED RED Keystone Electronics 5000

40 |1 TP14 TEST POINT 43 HOLE 65 PLATED BLACK | Keystone Electronics 5001

Special Jumper Installation Instructions

41 |1 Install jumper across pins 2 and 3 of J1 Sullins Electronics Corp. | STC02SYAN

42 |2 Install jumper across pins 1 and 2 of J4 Sullins Electronics Corp. | STC02SYAN
Install On Bottom of PCB As Close To Corners As Possible

43 |4 |r/a | BUMPER CLEAR.370X.19" CYLINDER [ Richco Plastic Co RBS-35
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A.3

A3.1

Board Schematic

CY3280-SLM Universal CapSense Linear Slider
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Embedded in Tomorow™

Board Layout

A.3.2

Figure A-5. Primary Side
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A.3.3 Bill of Materials

Iltem | Qty. Reference Part Manufacturer Mfr. Part No.

1 CY3280-BBM PCB Cypress

2 5 B1,B2,B3,B4,B5 Copper CapSense Pads Cypress n/a

3 1 Css1 Copper CapSense Slider Cypress n/a

4 5 D1,D2,D3,D4,D5 LED RED CLEAR 1206 REAR MNT SMD LITE-ON INC LTST-C230CKT

5 1 J1 CONN HEADER .100 DUAL R/A 44POS Sullins Electronics Corp. PBC22DBAN

6 1 J2 CONN HEADER VERT 3POS .100 30AU AMP Division of TYCO 87220-3

7 5 R6,R9,R10,R13,R14 |RES 1K OHM 1/10W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ102V
Special Jumper Installation Instructions

8 | 1 | | Install jumper across pins 2 and 3 of J2 | Sullins Electronics Corp. | STCO02SYAN

Place on bottom of PCB as close to four corners as possible

9 |4 | | BUMPER CLEAR.370X.19" CYLINDER | Richco Plastic Co | RBS-35

Do Not Populate

10 1 Ul IC EEPROM CMOS SERIAL 256X8 SO-8 Microchip Technology 24L.C02B-I/SN

11 |6 R2,R3,R4,R5,R7,R8 | RES 10K OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ103X

12 4 TP1,TP3,TP5,TP7 TEST POINT 43 HOLE 65 PLATED RED Keystone Electronics 5000

13 |2 TP2,TP4 TEST POINT 43 HOLE 65 PLATED BLACK | Keystone Electronics 5001

14 1 R1 RES 40.2K OHM 1/10W 1% 0603 SMD Panasonic - ECG ERJ-3EKF4022V
15 1 RT1 THERMISTORS 10K OHM NTC 0805 SMD | Murata NCP21XV103J03RA
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A4 CY3280-BBM Universal CapSense Controller Board
A4l Board Schematic
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Embedded in Tomorow™

A.4.2 Board Layout
Figure A-7. Primary Side
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Figure A-8. Secondary Side
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A.4.3 Bill of Materials
Item | Qty. Reference Part Manufacturer Mfr. Part No.
1 1 PDCR-9415 CY3280-BBM Cypress
2 1 |n CONN HEADER .100 DUAL R/A 44POS iz'rlg‘s Electronics PBC22DBAN
3 5 P1,P2,P3,P4,P5 CONN RECT 8POS .100" VERT 3M 929850-01-08-RA
4 4 TP1,TP3,TP5,TP6 TEST POINT 43 HOLE 65 PLATED RED Keystone Electronics 5000
5 2 TP2,TP4 TEST POINT 43 HOLE 65 PLATED BLACK Keystone Electronics 5001
6 1 TERMINAL STRIP 3M 923273-1
Do Not Install
7 2 ci,c2 CAP 10UF 16V TANTALUM 10% 3216 AVX TAJA106K016R
8 |1 | CONN HEADER .100 DUAL R/A 44POS g‘(‘)'rlg’s Electronics PBC22DBAN
R1,R2,R3,R4,R5R6,R7,R8,
R9,R10,R11,R12,R13,R14,R
15,R16,R17,R18,R19,R20,R .
9 34 21.R22.R23.R24.R25.R26.R RES ZERO OHM 1/16W 0402 SMD Panasonic - ECG ERJ-2GEOROOX
27,R28,R29,R30,R31,R32,R
33,R34
10 1 Ul IC REG 3.3V 800MA LDO SOT-223 National Semiconductor | LM1117MPX-3.3
11 1 u2 IC EEPROM CMOS SERIAL 256X8 SOIC-8 Microchip Technology 24L.C02B
Place on bottom side as near to corners as possible:
12 | 4 | BUMPER CLEAR.370X.19" CYLINDER Richco Plastic Co RBS-35
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